1

I bought a brand new MacBook and set it up earlier today.

Went through setup, updated to High Sierra, enabled FileVault with a recovery key, wrote that down and then shut it down at some point. When I tried to log in again, it wouldn't let me. Wrong password. OK, I thought, I have the recovery key. So I log in using that, change my password, restart and run into the same issue again. New password doesn't work. Next time I tried with a fool-proof password "123456" - no luck. The password somehow gets reset to something I don't know on restarts.

Next I tried to reinstall my system but I can't do that because the HD is locked with the password I don't know. Then I figured I'd try to disable/reenable FileVault but that also doesn't work as suddenly my account, despite being the only account and admin, isn't eligible to change FileVault settings.

What can I do here?

  • If you boot into recovery mode, can you run disk firstaid? – moneyt Jan 5 '18 at 19:51
  • Not on Macintosh HD, no – welluhmok Jan 5 '18 at 19:54
  • Can I delete Macintosh HD in Disk Utility or will it delete the part that lets me reinstall my OS on the next boot as well? – welluhmok Jan 5 '18 at 20:15
  • 1
    I believe you should see 2 partitions under your drive in the disk utility correct? One called MacintoshHD and the other named something like "Sierra 13.2"? If so, you should be able to wipe MacintoshHD and install from recovery too. Even if you wiped the whole disk, it is possible to boot into recovery mode over the internet support.apple.com/en-us/HT201314 but before you did anything too drastic, since you just bought the machine, it's probably worth your time to call Apple Care – moneyt Jan 5 '18 at 20:28
  • Thanks, I'll probably do that. Tried the procedure described under "Reset using your Recovery Key (FileVault must be on)" here in the meantime but sure enough I can't do it because I don't know the password to unlock Macintosh HD... – welluhmok Jan 5 '18 at 20:38

You must log in to answer this question.

Browse other questions tagged .