2

first of all I must say I'm pretty amazed by all the help and great contributors on this site. I already tried a few different Solutions but I came to a point where I couldnt help myself furthermore.

Windows Installation failed

I tried to install Windows 8.1 on my 27" Retina iMac Late 2016 with 1TB of Fusion drive. Everything went fine, after the Bootcamp Setup the Windows Setup started.

During the Windows Setup i was asked to choose a Drive to install on. Since I created a 200GB partition with Bootcamp I wanted to use this, Windows denied to install it. I'm very sorry I can't remember what windows told me.

I formated the partition with windows hoping it would work afterwards. It didn't. Then I deletet the partition hoping creating a new one with windows would solve it. It didn't.

I canceled the windows installation and booted Macintosh. Bootcamp told me it couldn't start an installation because it's not formatted.

Bootcamp Partition deleted

I decided to delete the Bootcamp partition, soon after I realized how stupid this would be. Anywys Bootcamp itself never offered me to remove Windows. So I kind of had no choice.

I could not delete the 150MB "disk1s5" for whatever reasons but after a while i created an empty journaled "WINDUMB" partition which I couldnt resize. My Mac told me it cannot be resized. Also the [-] wasn't clickable.

I deleted WINDUMB to ExFat, FAT and APFS. APFS let me click [-] but deletion failed.

Recovery Diskutil

In recovery, following this Problem and another Solution (found on another forum) that would just delete CoreStorage wouldn't work.

I could not resize my cs. My mac tells me that I cannot resize a volume that exists on 2 physical drives or something like that.

David Anderson 'Partition Recovery' Approach

Worked fine but my diskutil didn't load after deletion so I had to restart. After restart my Diskutil just shrinked my Fusion Drive to 809,9GB instead of showing "empty space". I coulnd't work it out with First Aid.

Solution Request

  • I'd like to recover the lost ~200GB of Storage from the deletion
  • The recovered disk space should be merged with Macintosh HD
  • Windows may still be an issue if possible. Hints for successful installation are welcome, otherwise I might research for issues using a fusion drive with windows

Annex Data

Sorry for the German Menu. This is showing "About this Mac" and my Diskutil

/dev/disk0 (internal, physical):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *1.0 TB     disk0
1:                        EFI EFI                     209.7 MB   disk0s1
2:          Apple_CoreStorage Macintosh HD            786.4 GB   disk0s2
3:                 Apple_Boot Recovery HD             8.6 GB     disk0s3
4:                        EFI NO NAME                 104.9 MB   disk0s4

/dev/disk1 (internal):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                         24.0 GB    disk1
1:                        EFI EFI                     314.6 MB   disk1s1
2:          Apple_CoreStorage Macintosh HD            23.6 GB    disk1s2
3:                 Apple_Boot Boot OS X               134.2 MB   disk1s3

/dev/disk2 (disk image):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        +2.1 GB     disk2
1:                  Apple_HFS OS X Base System        2.0 GB     disk2s1

/dev/disk3 (internal, virtual):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:                  Apple_HFS Macintosh HD           +809.0 GB   disk3
                             Logical Volume on disk1s2, disk0s2
                             C079CDA8-4E21-4BCC-B281-41BA78F50486
                             Unencrypted Fusion Drive

CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 20AC74D8-2E29-49D2-87A4-38C21ED66735
=========================================================
Name:         Macintosh HD
Status:       Online
Size:         809904775168 B (809.9 GB)
Free Space:   65536 B (65.5 KB)
|
+-< Physical Volume 0C14352D-8A15-4921-A012-F3650C3CF445
|   ----------------------------------------------------
|   Index:    0
|   Disk:     disk1s2
|   Status:   Online
|   Size:     23553724416 B (23.6 GB)
|
+-< Physical Volume 119FE525-BFA6-446A-A688-8DC77BD89687
|   ----------------------------------------------------
|   Index:    1
|   Disk:     disk0s2
|   Status:   Online
|   Size:     786351050752 B (786.4 GB)
|
+-> Logical Volume Family AA7CF748-19B1-4206-85C8-EA12A99F8176
    ----------------------------------------------------------
    Encryption Type:         None
    |
    +-> Logical Volume C079CDA8-4E21-4BCC-B281-41BA78F50486
        ---------------------------------------------------
        Disk:                  disk3
        Status:                Online
        Size (Total):          808999976960 B (809.0 GB)
        Revertible:            No
        LV Name:               Macintosh HD
        Volume Name:           Macintosh HD
        Content Hint:          Apple_HFS
        LVG Type:              Fusion, Sparse

EDIT: Requested Data Annex

       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-      00A0C93EC93B
      409640  1535841896      2  GPT part - 53746F72-6167-11AA-AA11- 00306543ECAC
  1536251536    16894320      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  1553145856      614400         
  1553760256      204800      4  GPT part - C12A7328-F81F-11D2-BA4B- 00A0C93EC93B
  1553965056   399560079         
  1953525135          32         Sec GPT table
  1953525167           1         Sec GPT header


Resize limits for partition disk0s3 Recovery HD:
  Current partition size on map:              8.6 GB (8649891840 Bytes)
  Minimum size (constrained by file usage):   591.9 MB (591880192 Bytes)
  Recommended minimum size (if used for OS):  6.0 GB (5960589312 Bytes)
  Maximum size (constrained by map space):    8.8 GB (8830246912 Bytes)
1

I usually do not answer questions involving Fusion Drives. Primarily, because there are others who have more experience than me.

I believe the commands below will return the free space to your "Macintosh HD" volume.

diskutil  eraseVolume  free  n  disk0s4
diskutil  resizevolume  disk0s3  650M
diskutil  unmount  disk0s3
diskutil  cs  resizePV  119FE525-BFA6-446A-A688-8DC77BD89687  0
diskutil  cs  resizeLV  C079CDA8-4E21-4BCC-B281-41BA78F50486  0
  • Thank you for your response, I was hoping to get your attention! I added the requested outputs. Also I'd like to recover the drive first to have a roadmap to go if my drive configuration would fail again. I'm still thinking of having a windows partition later - after more research. – Sascha Braband Jan 6 '18 at 1:02
  • I could successfully resize the Recovery HD and recover the lost disk space using your commands! Thanks, David! – Sascha Braband Jan 6 '18 at 13:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .