4

I have used the afp protocol to share between Macs on my local network.

I normally connect using a command like the following:-

open afp://Thylacine.local

This then prompts for a shared directory to connect to.

I have experienced some difficulties since upgrading to High Sierra.

My wife has a new Macbook Pro, which she setup by copying from a TimeMachine backup from her old Mac (running Sierra) then upgrading to High Sierra.

I can access the old Mac with no issues.

I have checked and double checked. Sharing (using afp) has been enabled, and there are a number of shared Directories.

Any attempt to connect fails because there are no shared directories.

I tried using my daughter's laptop MacBook Air (13-inch, Mid 2012) also running High Sierra 10.13.2 This exhibits similar difficulties, although bizarrely it offers to share 2 mounted external Volumes. I can access her Mac using Screen Sharing.

Can anyone suggest what is wrong, or any other steps I might follow.

I have just tried connecting from my daughter's MacBook to mine (also running 10.13.2) and this seems to proceed flawlessly.

7

https://support.apple.com/en-us/HT207828

AFP can’t share files on Apple File System (APFS). Apple File System (APFS) is the default file system in macOS High Sierra for Mac computers with all-flash storage. You can't opt out of the transition to APFS when you upgrade a Mac with all-flash storage to macOS High Sierra.

If you need to share files, switch to SMB. If you have network home directories shared via AFP on an APFS volume, update the mount records and user records to use SMB.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .