0

After installation of iOS 5, once it was done restoring my settings, apps, etc I got an error message -19. All apps restored successfully. But I don't see the photos. I tried to revert to iOS 4.3.3 again but I got stuck again with error -10.

At this point, I just want my photos back. After that I can update the iPhone to the latest version. Is there a way to restore the photos from the iPhone's file system? I tried accessing the phone's contents using Ubuntu, there I got error message 15.

  • Did you already have a look at the instructions in support.apple.com/kb/TS3694? Can you still access your phone directly or does it just show the "Connect to iTunes" screen? – nohillside Nov 13 '11 at 18:09
  • I couldn't find 10. 19 is basically an unknown error! I tried the solution which was eject-connect again-update. But it didn't work. – Mohammad Moghimi Nov 13 '11 at 19:42
  • BTW, The phone is perfectly fine. I just lost my photos. – Mohammad Moghimi Nov 13 '11 at 19:52
  • So, the phone works but your photos are gone? Do you have a recent backup in iTunes and did you sync your photos at all? – nohillside Nov 13 '11 at 19:54
  • Unfortunately no! I don't have them on my PC. I was just relying on the backup the iTunes does before the update. That backup took very long so I slept and in the morning I saw that I don't have the photos anymore :( – Mohammad Moghimi Nov 13 '11 at 20:00
1

According to Apple, iTunes should automatically backup your photos and videos:

Backed-up information includes purchased music, TV shows, apps, and books*; photos and video in the Camera Roll; ...

However, the format of the backup doesn't make it easy to access those photos. Therefore, you can use a program such as iPhone Backup Extractor which should make it a lot easier to recover data from the backup, including photos. I haven't tried the app, so I can't personally recommend it, but it did get good reviews on CNET.

0

Try searching for previous backup data in iTunes folders:

your user folder > Library > Application Support > MobileSync > Backup

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .