0

Context

Some applications currently don't seem to allow copy and pasting.

For example I have an application that asks me to log in every time and it doesn't allow me to paste anything so I'm forced to type a very long and complicated password every time.

I don't think it's something they intentionally restrict but rather a limitation of the libraries they are using (maybe xQuartz?).

What I've tried

I've tried cmd+C and cmd+V in the input area. I've also tried to right-click and click on "Paste" (which is highlighted) but that also yields nothing.

Question

In any case, is there any way to simulate pasting on Mac OS X? Maybe by sending multiple key presses instead?

  • Cmd-V (paste) doesn't work? That would be your "multiple key presses" – Allan Jan 4 '18 at 14:51
  • @Allan Nope, that doesn't work. Isn't that the standard "paste" shortcut? – Shoe Jan 4 '18 at 14:54
  • 1
    It's helpful if you provide details like what you've tried already so we don't duplicate efforts and expand on the application - it's extremely difficult to solve an actual problem based on a hypothetical description. – Allan Jan 4 '18 at 15:01
  • Assuming you're copying from a 'regular' copiable location, try right click/paste in the troublesome area – Tetsujin Jan 4 '18 at 15:03
  • @Allan I've updated the question. – Shoe Jan 4 '18 at 15:37
1

Turns out the problem was that the copied password (and the one with which I thought I registered) was longer than 20 characters. The input field on the application doesn't allow more than 20 characters long password and the website silently cuts them to 20.

By copying the first 20 characters of the password I was able to paste it in.

You must log in to answer this question.

Not the answer you're looking for?Browse other questions tagged .