I have a MacBook Pro (Retina, 15-inch, 2015) connected to 2 LCD monitors: one through VGA and one through DVI. Text in both this monitors look awfully blurry.


enter image description here

Things I've tried:

  • Settings > Preferences: Font smoothing enabled/disabled (makes no visual difference at all).

  • AppleFontSmoothing set to 0, 1, 2, 3.... also no visual difference.

  • The edid patch to foce RGB also didn't work (applied the patch succesfully but didn't make any visual difference). Didn't remove it though and my color profile is set to 'Forced RGB'.

Same monitors in a Windows machine don't present this problem (at least the one connected through DVI, VGA looks a little off too but that might be the connection).

Any ideas?


Edit: Additional details. Monitors are both the same, Lenovo E2323. No settings aside from contrast, brightness, colors, clock... basic stuff.

  • Only text or other things too?
    – JMY1000
    Commented Jan 4, 2018 at 9:13
  • I'm noticing it on text. But it seems that text within images have the same problem so maybe the problem lies elsewhere? Commented Jan 4, 2018 at 9:23
  • Another thing: taking a picture of the XCode welcome page, half an 'n' seems to be missing. If I move that window to the integrated display it looks fine. If I take a screenshot in my external display and move that picture to the integrated display it is still missing half an 'n'. Commented Jan 4, 2018 at 9:25
  • Are you using the external monitors at their native resolution? If they are being used at the macbook's resolution dots won't matchup. Not all VGA cables are created equal. Try a different make of cable. The mini-port to VGA/DVI adapters can be flaky, especially after market ones. Swap with someone. Commented Jan 4, 2018 at 20:35
  • 1
    any update use another cable @RisingConcupiscence ? Commented Feb 20, 2018 at 13:30

3 Answers 3


It will look blurry because Apple designed their system to look best on retina (high PPI, around 200) displays. I've been trying out everything but nothing works, except one thing - running Windows in bootcamp or remote session.


I had the same issue with a 1080p monitor connected to my 13" rMBP. Mine doesn't have a DVI port so I couldn't try that, but I did try the other stuff:

  • Connecting from MDP to HDMI, MDP to VGA, HDMI to HDMI. Nothing helped.
  • Font smoothing from preferences or 0, 1, 2, 3: This produced a very slight difference, but not enough to keep my eyes from getting sore from all the pixelation.
  • Forcing RGB output using the EDID script. No noticeable change, apart from the same profile change as yours, it's set to 'Forced RGB' now.

I did find something that works for me, and I recommend you try it too. Download a trial of SwitchResX and try setting the resolution to one of the resolution from the HiDPI list. The difference was immediately noticeable when I switched from a HiDPI scaled resolution to a non-HiDPI resolution in the list. Apple probably only likes HiDPI monitors for Mac, and doesn't show a HiDPI option in the scaled display options on 1080p monitors like ours.

I'm using the scaled 1280x720 HiDPI resolution in SwitchResX and that fixed the awful blur for me. Some pixelation is still there which is probably expected from a 1080p monitor compared to the 1600p on my rMBP, but the monitor is now usable.


Same MacBook. My brand new Samsung C49RG90 connected in Picture-by-Picture mode with the two display-port outputs exhibited awful fonts. I found out that by simply reducing the default sharpness setting of the monitor from 60 to 50 fixed everything - no need to tweak AppleFontSmoothing or CGFontRenderingFontSmoothingDisabled.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .