1

I have an issue where the mouse cursor(I-beam) on my Mac (High Sierra) is extra large. The large size only appears when viewing this Mac via Screen Sharing - the client Mac I'm on shows the correct size for the mouse cursor in local application, but whenever I select/hover text in the remote/host Mac the mouse cursor is huge. If I look at the local display for that Mac, the mouse cursor is the correct size, so it's not a system setting on the host, but some kind of display issue with Screen Sharing itself.

Does anyone have any idea how I might be able to reset this or adjust the size? (See below for a screen grab showing the large cursor on the far right. Compare with the second image showing the correctly-sized cursor, grabbed from the host Mac.)

screenshot of large text cursor

enter image description here

Update: It appears that this only happens in certain applications. I get the large cursor in apps like iTerm and VS Code, but not in other text editing apps like Sublime Text, TextEdit, etc. - even if the selected display font for each app is the same. This just leaves me even more confused.

  • It could be something with the auto scaling. Try using the different scaling options and enable/disabling different quality options. Also is the default monitor of the client a different size than the remote? – Unassuming Guy Jan 4 '18 at 20:24
  • I have indeed tried adjusting the scaling/quality options, to no effect. The client does have a much larger screen than the remote, but I'm not sure why that would cause this kind of a display issue. Oddly, I don't recall this being an issue with Sierra (just High Sierra). – angrychimp Jan 4 '18 at 21:01
  • If I use RealVNC VNC Viewer, the cursor is just fine. I'd honestly use that if (a) clipboard syncing was better and (b) performance wasn't worse. – angrychimp Jan 4 '18 at 22:13

You must log in to answer this question.

Browse other questions tagged .