This is not about the iPad not charging over a USB connection. My device refuses to charge both over USB and the charger that came with it.

I got my iPad 2 with iOS 4.3.5 just about 10 days ago. It has had 2 recharge cycles without problems, now on the third it refuses to charge. Connecting it to a USB port on a PC it shows "Not Charging" as it always did, but syncs fine. Connecting it with the charger, the battery icon shows the lightning symbol, indicating that the device thinks it's charging, but even after 10+ hours the battery status never increases by even 1%.

Researching on other sites and asking friends who own iPads, it seems most people who are having charging problems report that their iPad never even shows the lightning bolt. Mine, however, definitely thinks it's charging, it just doesn't. I tried the following:

  • Tried charging with a different cable and charger pack from a friend's iPad.
  • Did a soft reset
  • Did a hard reset
  • Did a complete restore back to factory settings (which updated to iOS 5.0.1)

However, I still cannot charge the battery. Is there anything I can still try, short from bringing the device in?

  • Maybe some dust got stuck in the port but that's already a very wide guess.
    – nohillside
    Nov 13, 2011 at 15:52
  • 1
    Not that I can think of… I would definitely bring it back to the Apple Store ASAP.
    – TJ Luoma
    Nov 13, 2011 at 15:52
  • A ten day old iPad can be taken back to an Apple store or dealt with on the phone with Apple. Let Apple resolve this for you, it will cost nothing and you'll probably get a new iPad if there's a problem with the current one. Just back up the current one before you take it in.
    – Richard
    Nov 14, 2011 at 3:18
  • Thanks for the comments, I brought it in a few days after. Not to an Apple Store, since their customer service seems way too roundabout, but to an authorised service partner. I got a new iPad 2 the next day, no hassle. Dec 4, 2011 at 21:07

1 Answer 1


It turns out that it was indeed a faulty battery, and there's nothing that I could have done. I got a new iPad 2 under warranty, and its battery lasts almost twice as long from a full charge as well, so it was in fact broken from the outset.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .