The phone has never been jailbroken. Never got wet, anything. But after one night it reboot, and got stuck. The battery overheat and even after a few attempts to solve the issue through iTunes, Recovery and DFU mode, it continues stuck at the same part of the boot. I really don't know what to do anymore. It is an iPhone 7 Plus 256, 2 months without warranty! Thats the worst!! I'm running iTunes on a MacBook Pro

  • 1
    So you tried the Recovery mode using pc?
    – razvanelda
    Jan 3, 2018 at 17:54
  • Both, PC and Mac
    – Luis Bedin
    Jan 3, 2018 at 18:07
  • 1
    Well try to take it to the service, it is probably something wrong with the hardware.
    – razvanelda
    Jan 3, 2018 at 18:10
  • 1
    Thats what I fear. Only 2 months out of warranty. Its kind of frustrating
    – Luis Bedin
    Jan 3, 2018 at 18:25
  • Yes, but it is more frustrating not to have a functionally phone :))
    – razvanelda
    Jan 3, 2018 at 18:33

3 Answers 3


Many things can cause a boot-looping device.

Try these things (if you haven't already) to see if anything helps:

  • Try a hard reset (Home & Power button for 10 secs)
  • Use a genuine Apple Lightning connector
  • Use a genuine Apple charging brick and let it charge overnight
  • Try to connect it to different computers (mac/pc if possible) with an updated iTunes
  • Put the phone in recovery mode (search DFU Mode). Careful, this can reset your data
  • Use 3uTools for putting it in and out of Recovery Mode
  • Use 3uTools to flash the firmware (you can't downgrade)

If you are comfortable opening your device (now that it's out of warranty) then consider the following:

  • Disconnect the Front Camera Ribbon from the logic board and reboot your phone
  • Disconnect the screen assembly completely and see if iTunes will recognize the phone.

Otherwise, you may have a logic board issue. If you are uncomfortable doing these steps, consider either doing an OOW replacement at Apple or finding a reputable, independent repair shop to do the troubleshooting. A shop that also does micro-soldering can go deeper if the problem is not modular in nature.

  • I've tried the DFU mode on iTunes. I'm not comfortable to jailbreak it with 3u, and really don't want to open it. I think I have to go to the store and spend some money. =( Thank you
    – Luis Bedin
    Jan 4, 2018 at 11:18
  • I wasn't implying Jailbreaking. You can use 3uTools to flash original Apple iOS versions. Obviously you can't downgrade.
    – Minho
    Jan 4, 2018 at 15:52

The next best thing is to restore the iPhone software. Meaning erase the software and then using iTunes on a computer to restore the software with a refreshed iOS 11.0.2.

Backup iPhone via iCloud (optional but highly recommended)

Plug in iPhone to iTunes and click restore iPhone. iTunes should also automatically backup the iPhone also. - https://support.apple.com/en-ph/HT201252 **Make sure iTunes is up to date and then restore.

Once restore is done you are going to get the hello screen on the iPhone. Set up the iPhone properly then when you get the Apps & Data screen, restore from iCloud backup (unless you chose not to back it up). - https://support.apple.com/en-ph/HT204184

Then your phone should be back up and working with your stuff back on it and the software cleaned up.

  • Hasn't worked, =(
    – Luis Bedin
    Jan 4, 2018 at 11:21
  • @LuisBedin then give it a try again but don't restore your backup. Your files could be corrupt on the software. If you still experience the problem with stock iOS then it's power related. I suggest taking it to the Apple store for a battery replacement. But make sure you restore the iPhone to stock 1st without your backup info on it (set up as new). If you get the battery replaced but you didn't do the setup as new, it'll happen again on the new battery. Jan 4, 2018 at 14:10
  • Also delete the downloaded update on iTunes. Go into finder, then click Go above, then press and hold option and choose library. Then choose iTunes and delete iPhone software updates. Jan 4, 2018 at 14:12

i had exactly the same issue keeps botting in a loop took me a while to figure it out and i know this sounds stupid first of all disconect the battery then take the screen off no need to remove the ribbons put a piece of cardboard on top of the metal sim card holder i used a rizzla cardboard connect the battery conector close the screen switch on boom it working. ive bought a few off ebay same thing all working now.

  • Please consider rewriting and proofing what you wrote. It's very difficult to understand what you are attempting to convey. As written, it's quite likely to be down voted.
    – Allan
    Mar 1, 2018 at 23:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .