1

On my Macbook with a US-International physical keyboard, the windows of one application are cycled with CMD+`. Now I also use an iMac that has a German keyboard (the printing on the keys). I switched the layout to US-International, but weirdly, the windows of one application are now switched with CMD+> instead. This is exactly the key that would be in the same location as CMD+` would I be using the German keyboard layout. I am not using that layout, though and I don't want to cycle windows with CMD+>.

How can I customize this setting?

  • Just to clarify - the position of the key moves, depending on Language? or... you're conflicted because you want the key to be above Tab [US keyboard types] rather than left of Z [almost all other keyboard types]? See apple.stackexchange.com/questions/193937/… – Tetsujin Jan 3 '18 at 12:32
  • No matter the keyboard layout that is selected (in software), on this Mac <kbd>CMD</kbd>+<kbd>></kbd> switches the windows. If I (in software) select the german layout, then this is next to the left shift, if I select the US layout it is in the bottom right. – Thomas Jan 3 '18 at 13:33
  • To answer the question. I want it to be left of Z and use a US-International layout. For this the window switch needs to be evoked by "CMD+`". Currently it is evoked by CMD+> – Thomas Jan 3 '18 at 13:35
  • OK, then you're probably stuck - though you can pick a key, it's going to move with your language selection. There's a method to change the key in the last part of my answer on the linked QA – Tetsujin Jan 3 '18 at 13:36
  • 1
    I added a picture. – Tetsujin Jan 3 '18 at 13:47
1

The language specific shortcuts are set up when the computer is first set up. In my case, the computer was set up in German and I only later switched it to English. Then the default hotkeys do not change. The desired behaviour (switching windows with CMD+' could be enabled by going to System Prefs > Keyboard > Shortcuts > Keyboard and then pressing "Restore defaults". In particular "Move focus to next window" changes then.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .