2

A couple days ago, I was streaming a show on the internet when suddenly the internet stopped working. I closed my tabs and restarted my WiFi but to no avail. I checked to see if the internet was functioning as usual on my phone and it was. Therefore, this must be an issue with my device- a MacBook air- and not with the router.

So far I:

  • ran diagnostics and according to that, everything is in working order.
  • renewed the DHCP lease.
  • made sure it wasn't a dns issue.
  • reset SMC and NVRAM
  • cleared my browser cache
  • checked my download folder for anything suspicious
  • restarted many times, both in safe mode and recovery mode

None of the above has worked. It doesn't matter whether I try using Chrome or Firefox or Safari or an application requiring internet connection. Nothing works. On chrome it tries to load for a while before saying connection timed out.

Any ideas on how I might resolve this issue?

I'm worried that I may have gotten a virus from the streaming website but I can't install an antivirus software now without internet access.

  • If the WiFi connection is not working in recovery mode either, it seems unlikely that a virus should have caused it. Have you tried taking your MacBook Air to a different location and connect it to a different WiFi? (or even just share the internet connection from a smart phone and try connecting to that network instead) – jksoegaard Jan 2 '18 at 22:47
  • Does Ethernet work? – abc Jan 2 '18 at 23:05
  • Your statement that Therefore, this must be an issue with my device- a MacBook air- and not with the router. is not necessarily the case here. One thing to try is to switch off your router for at least a minute and then reboot it. After reboot, test again with both your MBA and phone to determine if you still have an issue. If this doesn't work, then the suggestion by @jksoegaard is an excellent next step. – Monomeeth Jan 2 '18 at 23:06
  • @abc Testing Ethernet is a good troubleshooting option assuming the OP has some sort of Ethernet adapter. MBAs don't have a native Ethernet port. – Monomeeth Jan 2 '18 at 23:10
  • To make the comparison with your iPhone useful, please turn off Settings > Mobile Data and check you can reach the web with Safari. Add this key information within your OQ. – dan Jan 2 '18 at 23:27

You must log in to answer this question.

Browse other questions tagged .