I find it annoying and get no use from it. Here's a picture of what I'm talking about:

enter image description here

  • Have you tried ignoring it? – John Keates Jan 3 '18 at 0:43
  • 1
    @John Don't judge me. – Luke Davis Jan 3 '18 at 4:19

The bell is a visual indicator that the terminal bell "ringed".
You can disable it on a profile by orofile basis in the "Preferences" pane
Menu: Profiles | Open Profiles | Edit Profiles... | Terminal
in the "Notifications" section uncheck "Show bell icon in tabs"

  • This option appears to be for a different greyed-out icon that appears in Tab bars, not for the icon on the Window title bar. Try it out. – Luke Davis Jan 2 '18 at 21:38
  • I tried it before writing the answer. You can check it on the fly by using the "edit session..." contextual menu (right-click on the iterm2 window) and going in the "terminal" pane. It works for me. – Gio Valerio Jan 4 '18 at 0:14
  • I have the version 3.1.5 – Gio Valerio Jan 4 '18 at 0:27

This is behavior is controlled via the Show bell icon in tabs preference mentioned earlier, but if changing that setting doesn't appear to do anything, you may have a corrupt preferences file or cache. Please try the following:

  1. quit Iterm2
  2. open Apple's Terminal (in /Applications/Utilities)
  3. delete the following two items: ~/Library/Caches/com.googlecode.iterm2& ~/Library/Preferences/com.googlecode.iterm2.plist*
  4. re-launch Iterm2
  5. re-disable Show bell icon in tabs in Preferences > Profile > Terminal

Re-test to determine if issue is resolved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .