I have a 13-inch early 2015 Macbook Pro with Retina display, and today the keyboard and trackpad stopped working completely. (I have OS X 10.11.5 if that's relevant. I can't update to sierra, as a software I use is not compatible with it). The only thing that works is the power button. Now, this isn't unprecedented. This started happening a few weeks ago, but every time it happened, shutting down and restarting by holding the power button fixed the issue. But today it didn't.

I know there are many questions like this, but I tried every single solution I found. This probably means I won't get one here either, but I want to try this before I have to go to the Apple store.

I plugged in a USB keyboard to my laptop so that I could use it. I also plugged in a USB mouse, but that mouse plugs into the keyboard, not into the computer. Both worked fine. I tried an SMC reset and a PRAM reset, using both the built-in keyboard and the external keyboard for the required inputs, for a total of 4 attempted resets. I can't really tell if they did what they were supposed to or not, but they didn't fix my keyboard.

I booted in safe mode (using the shift key on the external keyboard. Using the one on my laptop didn't work, and it just booted normally), and the issue persisted.

The other solution I saw was to disable FileVault, but it was already disabled prior to this incident.

I also saw people saying plugging in a USB drive during login fixed the issue, but this didn't work either.

The last solution I tried was to let the computer sit while powered off and not connected to the battery. This didn't do anything either.

I did not spill anything on my computer prior to this incident, so I have no idea why it started happening. If anyone has solutions for this that I haven't tried yet, please let me know.

EDIT: I just noticed that if my computer is asleep, clicking the built in trackpad wakes it up. However, the trackpad doesn't do anything else.

4 Answers 4


You need to replace your top case assembly.

Your keyboard and trackpad (built in) are USB devices, so when you plugged in your external mouse/keyboard and everything worked, you effectively ruled out software issues. This is also confirmed when trying to boot in Safe Mode or doing NVRAM/SMC resets via the built in keyboard.

If it doesn't work in a pre-boot environment, it's not going to work at all.

The only option left is replacement of the top case assembly itself (Apple PN# 661-02361) and given that both have failed, it's highly likely that the USB interface on the keyboard has died.

Technically speaking, you could replace just your keyboard and trackpad, but it's an extremely labor intensive proposition. Whether you are replacing the keyboard/trackpad or the assembly itself, it will require a complete disassembly of the MacBook innards. iFixit.com has a writeup on the procedure and they rank it as "Difficult" with an allocation of 3 hours time.

Even if you don't plan on undertaking that repair yourself, I do suggest you familiarize yourself with the procedure to understand what's actually involved. Suffice to say, it will be an expensive repair.

  • That's unfortunate. As I said, I didn't spill anything, so do you have any idea what could've caused this? I want to make sure it doesn't happen again.
    – RothX
    Commented Jan 1, 2018 at 21:49
  • Also, I made an edit to my question. Probably doesn't make a difference, but letting you know just in case it does.
    – RothX
    Commented Jan 1, 2018 at 21:50
  • I'm sort of unclear. Are you talking about 2 separate procedures here, or just 1? And what do you mean, when you say "given that both have failed?" Both what?
    – RothX
    Commented Jan 1, 2018 at 21:51
  • 1
    Any number of things could have caused this type of failure. See this answer: apple.stackexchange.com/q/298853/119271 Unfortunately, you can't prevent defective components. The edit only re-inforces that it's hardware. Clicks are being recognized, but not motion. Both I am referring to is the track pad and keyboard. The config in the MBP is the same as your external mouse plugged into your keyboard. Given that both have failed, it tells me that the USB controller is the most likely culprit (it's the USB chip on the device, not logic board).
    – Allan
    Commented Jan 1, 2018 at 22:13
  • I second the suggestion to replace the top case assembly, as I have needed to do so on a similar machine. ALSO NOTE: The eason why the replacement was necessary was because the battery had aged to the point where it had started to swell and press against the machine's internals, deforming the trackpad/keyboard so that they (a) acted flakey, and shortly thereafter (b) failed completely.
    – Lexible
    Commented Jan 2, 2018 at 0:16

I fixed it by just pressing the strip holding the battery. NVRAM/SMC reset didn't work. But, the fix was only temporary. It occurred again and I think it's probably because of the battery swollen issue.


We ran into this problem, apparently it is a very common problem of the MacBook Pro 2015 as a series.

It's caused by a hardware problem, there is a cable between the touchpad and the motherboard that needs to be replaced.

We contacted some local experts and they fixed it in 2 hours.


I had a similar problem with an early 2014 Macbook Air. Did all the SW "fixes" listed on the web including re-installing/upgrading OS with no luck. Discovered that the keyboard/trackpad worked in recovery mode after boot but not in OS - implying a SW not HW issue. This observation proved incorrect. In the end, I replaced the trackpad ribbon cable in the laptop ($8 on Amazon) using Pentalobe, Torx drivers ($7 on Amazon). I opened the case and inspected the ribbon cable. There didn't appear to be any damage to the connectors but I replaced cable anyway (reference youtube videos). After reboot, keyboard and trackpad are working perfectly. Total cost of repair was < $20 for parts/tools.

It seems the ribbon cable is a delicate item in these machines. My only regret was not replacing the cable sooner.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .