3

I took a Time Machine backup to an external drive from old MacBook (Sierra) and then put it to a new one (High Sierra automatically) using macOS Recovery and "Restore From Time Machine Backup". Drive on the old Macbook was encrypted using FileVault but the backup I took wasn't encrypted as it takes ages to encrypt one.

Installation went fine and I was able to boot and setup the new MacBook, but now I can't turn on the FileVault. Trying to do so says "FileVault can’t be turned on for the disk “Macintosh HD”. Some disk formats don’t support the recovery partition required by encryption. To use encryption, reinstall this version of Mac OS X on a reformatted disk". I erased the data on the disk when using Restore from Time Machine and I thought it would've done the partition that way that using FileVault is possible. How should I make sure that if I now do Restore from Time Machine again it correctly sets up the disk for FileVault?

  • 1
    If I understand your question correctly you are trying to restore (or merge?) an encrypted Sierra system (i.e. CoreStorage) to High Sierra (probably APFS) (".. then put it to a new one (High Sierra automatically)... ")! This won't work as expected.... You would have to use the Migration Assistant. Or do you want to downgrade to Sierra on the new MB? – klanomath Jan 1 '18 at 14:23
  • I'm trying to migrate old Macbook to a new one, I tried using Migration Assistant, but encountered other issues trying to migrate through, got stuck the first time and other times got issues with user already existing, file paths, not being able to remove admin users etc., ran the Migration Assistant three times and wasn't able to get it working properly, so then tried to switch to Time Machine Restore, but got problems using it as well. Old machine is running Sierra but new one automatically loads High Sierra. Now whole macOS Recovery is giving -3403F -error though when trying to load it. – mpartan Jan 1 '18 at 15:35
  • If the new MB is High Sierra only (even if it's originally pre-High Sierra a firmware update may prevent installing/running Sierra) I'd try to update the old MB to High Sierra, backup with TM again and use the new backup to restore. – klanomath Jan 1 '18 at 15:49

You must log in to answer this question.

Browse other questions tagged .