1

I'm on MacOS High Sierra Version 10.13.2 and use Time Machine to back up to an external drive through an AirPort Extreme.

I've had this setup for years (~5, I think) and backups worked fine until earlier this year. The .sparsebundle file has a Date Modified of Apr 30, 2017... I don't know whether it broke after an OS update, or anything like that. When attempting a backup, I first get the following message:

Time Machine completed a verification of your backups on “Chris' AirPort Extreme”. To improve reliability, Time Machine must create a new backup for you.

and I click "Start New Backup". Shortly after, I get the following error:

Time Machine couldn’t complete the backup to “Chris' AirPort Extreme”. Time Machine could not delete the backup disk image “/Volumes/FreeAgent 3TB GoFlex Drive 0-3/Chris’s MacBook Pro.sparsebundle”.

I've bolded "0-3" because, the thing is, the name of my drive as connected through the airport is "FreeAgent 3TB GoFlex Drive 0" -- I have no idea why the plist file has "-3" in the path.

I had a go of editing /Library/Preferences/com.apple.TimeMachine.plist to change the "0-3" to just "0" (I did this by turning off automatic backups in Time Machine preferences, using plutil to convert the plist to xml1, edited in TextEdit, then converted back to binary1); however, when I turn backups back on and tell Time Machine to Back Up Now, it just overwrites the plist to include the "0-3" again.

Same goes for when I delete this plist, entirely -- a new plist is created with "0-3". Any ideas?

UPDATE: Before posting this, I tried a tip I found which advised to repeatedly delete the plist then restart until the plist stays deleted — this never happened (a com.apple.TimeMachine.plist file has always been present after restarting) but the “0-3” has changed to “0-2”.

2

You probably have some folders in your /Volumes folder that're conflicting with the Time Machine volume. You'll need to delete them, then find out what's creating them and get it to stop.

Deleting them: First, make sure the backup volume (FreeAgent 3TB GoFlex Drive 0) is not mounted; if it is mounted, eject it. Then in the Finder, choose Go menu > "Go to Folder" (or use the keyboard shortcut Command-Shift-G). In the "Go to the folder" dialog, enter "/Volumes" and click Go. This takes you to the normally-hidden /Volumes folder, which is where the various volumes your Mac has mounted (both local and network volumes).

If I'm right about the problem, you'll see folders named "FreeAgent 3TB GoFlex Drive 0", "FreeAgent 3TB GoFlex Drive 0-1", and "FreeAgent 3TB GoFlex Drive 0-2" inside /Volumes. You need to delete these, but first check out their contents to make sure there's nothing important in them, and also just to see what files exist -- that'll be a hint about what's creating these folders. When you're done checking them out, delete them. Note that it's not necessary to empty the trash, just to put them in the trash.

Ok, now an explanation of what I think is going on: when your Mac goes to mount the server volume, it tries to create an entry for it in /Volumes, named with the volume's name. All good so far, but what happens if some program tries to access a file or folder on that volume when it isn't mounted? Well, most programs access files by their paths, so the program will try to use /Volumes/FreeAgent 3TB GoFlex Drive 0/SomeFolderOrFile, and if that doesn't exist many programs will go ahead and create it, and store files in it. Then later you mount the actual server volume, and it can't put it at /Volumes/FreeAgent 3TB GoFlex Drive 0 because there's already something by that name. What it does is append "-1" to the name, and use that instead (unless there's something by that name, in which case it tries "-2", etc).

This creation of spurious folders has apparently happened three times on your system. Deleting the folders will fix it temporarily, but whatever created those folders is probably going to do it again and again unless you track it down and get it to stop. This is where you have to play detective: what files and folders got created inside those spurious folders, and what program uses them? For that matter, what program (other than Time Machine) is using that network volume? My guess would be that it's something that starts using the volume while Time Machine has it mounted, and then tries to continue using it after Time Machine has dismounted it.

(Time Machine itself shouldn't cause this problem. It uses aliases rather than just paths to locate its backups, and aliases let it be much smarter about e.g. mounting the server volume rather than just creating a folder by its name.)

  • Thanks, Gordon! You were absolutely correct about what I'd find in /Volumes – this has spawned two new issues: – Chris P Jan 2 '18 at 1:21
  • 1) com.apple.TimeMachine.plist is now completely missing in action – I have no idea where Time Machine is getting its info from. 2) Regardless, the error message still appears... while it's encouraging that it has just "0" (no more "0-1", "0-2", etc), it still can't delete the .sparsebundle. I tried to delete it myself and, no surprise, neither can I. As your answer was correct/helpful, it'll likely get my checkmark, but wanted to post this comment in case anyone can help, further. – Chris P Jan 2 '18 at 1:28
  • The point is now moot – I used the method here to delete the bands within my sparsebundle and, to my surprise, the backup went ahead without any issue the next time Time Machine tried. – Chris P Jan 8 '18 at 3:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .