1

Running High Sierra. I used a Seagate external hard drive and a Verbatim hard drive for Time Machine backup. Suddenly they are both not recognised by the iMac. The power lights are on and the disks are spinning. I have tried direct connection and via a usb hub. I have tried different cables. I have another Seagate hard drive which works fine in both the hub and direct connection and with all the cables. How do I wake up the 2 drives? Disk Utility does not recognise them either.

  • Please post the output of diskutil list (Terminal command) with your disks attached. – Allan Dec 31 '17 at 6:19
  • you might download the App Mountain from the Mac App Store and see if it will recognize and mount the drives. i've had very good luck this app. – jmh Dec 31 '17 at 6:31
  • Did the trouble occur after you upgraded from Sierra to High Sierra? – max_zorn Dec 31 '17 at 8:07
  • You don’t mention how old they are - could they both have failed? Or were they disconnected during a read/write operation? - trashing them? – Solar Mike Dec 31 '17 at 8:45
  • Not sure how old they are; I'd say both about 5 years. – OpaCas Jan 1 '18 at 13:40

You must log in to answer this question.

Browse other questions tagged .