16

I just purchased an iPhone 8 Plus which is running iOS 11.2.1. I am upgrading from an iPhone 6s which I never upgraded to iOS 11. When I make a phone call, the top right option used to be a toggle for just speakerphone. Now, it shows "audio" and there are multiple options. They are: my iPhone, Speakerphone, and my iMac. My iMac did NOT used to appear as an option, and I do not want it to appear.

I want to be able to toggle speakerphone with a single tap, like I used to do. How can I resume that behavior?

What I have tried

  1. Disable Handoff on the iPhone 8 Plus

    • Disable handoff under Settings > General > Handoff
    • Reboot the phone.
  2. Disable Handoff on my iMac

    • Uncheck the option under Apple logo > System Preferences > General > "Allow Handoff between this Mac and your iCloud devices"
    • Reboot the computer
  3. Turn off wifi on my phone

    • I was curious to see if the iMac would not show up as an option when wifi was disabled, because I don't know how it was being discovered by my phone. Even with wifi disabled, the option still appeared. It must be because both the iMac and iPhone are signed into my iCloud account.

None of the above options had any impact.

Here are screenshots of my experience

in-call screen audio options list

  • Has there been any update to this? I've tried everything on this forum and others (turning on/off wifi, turning on/off bluetooth, logging out of icloud which isn't reasonable) and nothing is working. The issue will be fixed for a few minutes and then the next phone call I get, it's back. This is so frustrating. I just want to hit the speakerphone button and get speakerphone! – Austin81 Jul 17 at 21:26
14

On your iPhone, go to Settings > Phone > Calls on Other Devices > un-check the Mac. Then switch off the "Allow Calls on Other Devices" toggle switch and restart the phone.

Also worth mentioning: simply switching off the "Allow Calls on Other Devices" toggle switch does NOT solve the problem - the Macs remain in the audio options list even if that option is off. You need to leave the option on and un-check each device before toggling the option off. You may not see the audio choices change until the phone is restarted.

  • 1
    I've done this, and it works for a day, but the Audio->Mac always returns in place of speakerphone. The "calls on other devices" settings remain as I left them (completely disabled). So I repeat another day. – jtheletter Feb 21 at 23:26
  • 1
    Just to confirm: are you making sure to leave the devices unchecked, but the Allow Calls on Other Devices setting checked? And have you restarted the phone? – Employee Feb 22 at 16:33
  • 1
    You suggest I untick all devices under "allow calls", but leave "allow calls" itself ticked (rather than unticking it after confirming all devices are unticked)? I've now done that, rebooted, it was fixed immediately, but it returned later that day. – jtheletter Feb 25 at 22:39
  • 1
    I tested it just now and it seems to work for me with "allow calls" both ticked and unticked. I remember that back when I posted this answer I was on iOS 11 and only having it ticked worked, but maybe it behaves differently on iOS 12 for some users. Might be worth posting this issue on the Apple Support forums to see if anyone else there is having the same issue on iOS 12. – Employee Feb 26 at 11:18
3

Try turning off Bluetooth on both devices. If it disappears with Bluetooth turned off then you may need to forget that Bluetooth connection on your iPhone with the Mac.

  • 3
    I cannot turn off Bluetooth on either one. The phone needs it to connect to the car, and the computer uses both Bluetooth mouse and keyboard. The phone is not paired to the iMac via Bluetooth. – boltup_im_coding Dec 31 '17 at 2:23
  • 1
    It doesnt have to be paired if the Mac and iPhone are set up with the same Apple ID. Its an automatic process. If you aren't using the computer turn off the computer. – Melvin Jefferson Dec 31 '17 at 2:32
  • 1
    You can always temporarily turn Bluetooth on and off whenever you need it. – Melvin Jefferson Dec 31 '17 at 2:33
  • 1
    I have this problem, and I rarely use Bluetooth and never leave Bluetooth enabled. – jtheletter Feb 21 at 23:27
3

i had the same problem and i solve it... in mac go to facetime and go to preference and just unclick the phone calls allow in this device...problem solved

0

I had the same problem and found the solution!

Settings Click on green button "Phone" Click on "Calls on Other Devices" Turn off "Allow Calls on"

  • 1
    This is the same solution as Mike's, posted three months prior. – jtheletter Feb 21 at 23:27
0

I’ve tried all of the above and what does work is switch off WiFi, then switch off phone, then start phone again and hey ... the speaker icon is back.

  • 1
    I've done this, and it works for a day, but the Audio->Mac always returns in place of speakerphone. The "calls on other devices" settings remain as I left them (completely disabled). So I repeat another day. – jtheletter Feb 21 at 23:26
-1

I disabled iCloud on my iPhone and that returned the speaker button to normal use.

  • 4
    I don't believe that's a viable solution as it will disable iCloud backup – boltup_im_coding Jan 7 '18 at 20:02

You must log in to answer this question.

protected by Community Jul 17 at 22:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .