Well, I've got a little problem with my SSD.

I had Windows installed through the bootcamp, when macOS offered me a High Sierra update. I've updated. But when I wanted to remove Windows, I could not do it. I had to delete it via the Disk Utility. And then I ran into a problem: I had 2 containers on one internal physical disk.

Divided ssd

But how do I unite them now, so that the empty merged with the system without loss of information?

Here is my diskutil list:

enter image description here

  • @klanomath thank you for quick response It seems I cannot get any output: gpt show: unable to open device 'disk0': Operation not permitted – Vladimir Bykov Dec 30 '17 at 19:46
  • Your forgot to prepend sudo – klanomath Dec 30 '17 at 19:47
  • So guys, what should I do now? How I can disable System Integrity Protection? – Vladimir Bykov Dec 30 '17 at 19:56
  • @klanomath sorry, my mistake! Yes, I have High Sierra – Vladimir Bykov Dec 30 '17 at 20:00
  • You may post the output of diskutil list. – klanomath Dec 30 '17 at 20:03

Use the commands given below to preform the merge.

Note: These commands will delete the noname volume, therefore you may want to backup this volume.

diskutil apfs deleteContainer disk0s3
diskutil eraseVolume free n disk0s3
diskutil apfs resizeContainer disk0s2 0

If a command fails, try prepending a sudo.

  • Also worked well for me. I merged two partitions on an external hard drive via diskutil mergePartitions ExFAT DesiredVolumeName disk2s1 disk2s2 – Nate Feb 10 '18 at 7:47
  • It worked for me on 10.13.5. – Parth Adroja Jul 8 '18 at 18:57

Below answer is given by Apple Tech Support guy.

Open terminal -> type distutil list -> type diskutil mergePartitions JHFS+ Macintosh disk0s2 disk0s4

Note: disk0s2 is the SSD disk0s4 is the disk which you want to erase and merge into main disk SSD.

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .