I have a VNC server (a QEMU VM to be exact) that I want to connect to, but I am experiencing a really strange problem. My server is on [ip]:5905 (or [ip]:5). When I try to connect to this server via VNC Viewer by RealVNC, it connects with absolutely no problems, except the Unencrypted connection warning. When I try to connect to exact same server using the built-in Screen Sharing app, it either tells me that it failed to connect, or it stays in an infinite “Connecting...” loop. What should I do?

By the way, I am trying to make a script that opens a connection to this VNC server, so I need arguments for the open command too. Thanks.

  • What make you think Screen Sharing is compatible with VNC? Commented Feb 4, 2018 at 12:19
  • According to this post from OS X Daily, it is. Am I wrong?
    – user255044
    Commented Feb 4, 2018 at 12:21
  • 1
    @DavidAnderson screen sharing was working connecting to VNC devices before the upgrade to High Sierra.
    – eduncan911
    Commented Sep 16, 2018 at 14:12

1 Answer 1


A few years later, I was running into this problem trying to install a Kali VM on my M1 Mac. When I tried to connect with Screen Sharing.app (with an empty password), it hung at "connecting..." but never worked. I could connect via tiger-vnc, but this wasn't working very well (screen lag, not updating, segfaults).

I eventually figured out that I needed to set a password in my VM configuration. Once a password was set, Screen Sharing.app connected right away.

My machine's XML config now contains:

<graphics type='vnc' port='5900' listen='' passwd='redacted'/>
            <model type='virtio' vram='32768'/>

With this configuration, open "vnc://:redacted@localhost" from the command line now works as expected (as does K in Finder, or open "vnc://$(whoami):[email protected]:900", or several other variations).

You must log in to answer this question.