0

I have tried a lot of things but I keep getting failed backups when doing a first backup on High Sierra. I have not used Time Machine previously and I am trying to backup to a usb drive.

Checking the logs after a failure I get something like:

Last failure:

 (TimeMachine) [com.apple.TimeMachine:TMLogError] Error: (-50) SrcErr:NO Copying /Volumes/com.apple.TimeMachine.localsnapshots/Backups.backup‌​db/<NAME OF MY COMPUTER>/2017-12-29-105925/Macintosh HD/usr/local/texlive/2015/texmf-dist/tex/latex/seminar/semin‌​ar.cls to /Volumes/Backup/Backups.backupdb/<NAME OF MY COMPUTER>/2017-12-29-105925.inProgress/15E91B0A-F367-4968-A9‌​48-04FF05E7404A/Maci‌​ntosh HD/usr/local/texlive/2015/texmf-dist/tex/latex/seminar 

The errors are always Error (-50) SrcErr:NO Copying and it is always some file from /usr/local (or /usr/) that fails. Could this have to do anything with permissions? I previously had Homebrew installed (which modifies the permissions for some of the subfolders of /usr/local/) and I also have Tex-Live 2016 installed.

Any suggestions on how to fix this would be greatly appreciated as I am pulling my hair out on this one.

0

Turns out that it was the hard drive that was the problem. Changing to another drive solved my problem.

Perhaps Error (-50) is an indication that the drive is failing? I am not sure, but I will leave this here in case someone else runs into the same problem.

Edit: I ran some diagnostics and the SMART test fails so it was definitely the disk.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .