3

My terminal frequently freeze with a spinning beach ball of doom. I've tested using both iTerm2 and the default Terminal, and it happens with both. And it doesn't seem to matter what I'm doing. I've had it freeze while nothing is running in any terminal, as well as while running a myriad of different programs (npm, webpack, gulp etc.).

When the terminals freeze, I'm able to force quit the app, but unable to start it again. And if one freeze, it seems to affect the other (if iTerm2 freeze and I force quit the app, I'm still unable to open Terminal). In order to use a terminal again I'm forced to reboot the machine.

While rebooting (after a terminal freeze) the machine also always hangs after closing all apps. I'm still able to move the cursor around on a black background, but that's it. The machine hangs there until I short circuit by holding down the power button.

What I've tried

I've tried resetting NVRAM and SMC to no avail.

  • You had two questions in here. This site works better when there is only one question per question. That way, it's easier for other people to find solutions if they have the same problem. I've edited out one question, but feel free to ask it separately. – nohillside Dec 29 '17 at 12:06
  • Are only the terminal applications frozen in these situations or do other applications show the same issue then? What does show up in Activity Monitor then? And (in reference to the other question you had) is the terminal problem occurring both with the external display connected and disconnected? – nohillside Dec 29 '17 at 12:08
  • Only the terminals freeze, other apps work (seemingly) fine. But as I noted, the subsequent reboot also hangs. Unsure what Activity Monitor says. I've tried combing through the Console for errors, but I'm unable to decipher those logs (sidenote: I'm seeing a bunch of "Month 13 is out of bounds" warnings). And yes, the terminals freeze regardless of the extra monitor. – o01 Dec 29 '17 at 13:20
  • any luck on this? happening to me now (on regular sierra, not high sierra). it happened after updating docker (which ive since removed). or maybe it was because i had a homebrew update script in bash_profile? i've deleted bash profile and terminal's plist but it still happens. as soon as i hit tab or something to make it access the filesystem, it beachballs and im stuck. – oooyaya Jan 27 '18 at 21:58
  • 1
    Actually, it could also be related to htop: github.com/hishamhm/htop/issues/682 – Mark Feb 2 '18 at 17:04
2

You are likely being hit by a macOS 10.13.2 kernel bug, described here, and exposed pretty regularly by htop, described here.

Supposedly, macOS 10.13.4 beta has a kernel fix, and version 2.10.0 of htop was released to work around this bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .