I reset my MacBook to factory settings 4 weeks ago, after I started having issues with missing libraries, etc., after messing around with a few 3rd party applications (SDKs and such).

After resetting I recognized that my device wouldn't connect to a particular network. It keeps asking me for the WPA2-Enterprise credentials, although previously provided credentials were 100% correct.1

Today, in addition to previous problems, I can't connect to a specific access point including when in "Recovery Mode".1

On top of all that, I cannot connect to certain websites, such as iCloud or DropBox, although both services are available when using a different device.

I already tried to flush my DNS cache and changed the DNS server.

At this point I have no clue what is left to do. Apparently this issue arose a few times in the past, with older setups, yet none of the solutions posted for those times did work out for me.

Has anyone run into these issues before and been able to solve them?

In case it is needed, my device:

macOS High Sierra Version 10.13.2

MacBook (Retina, 12-inch, Early 2016)

1 I can access both devices using my mobile phone, even though I never connected to these devices with my phone before.


I disabled the 2.4ghz bandwidth of a router I used previously, as well as the password. Now it seems to connect; although having an unsecured connection is not a good option.

1 Answer 1


Have you tried to reset PRAM?

  1. Shut down computer
  2. Turn on computer
  3. Hold down command, option, p, and r keys
  4. Release keys after power on sound and apple logo appears

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .