1

I have a MacBook Air (10.13.2). I'd like to play videos full screen on an external monitor, while still being able to continue working on my MacBook. I can't get it the way I'd like.

Whenever I click back on my MacBook, the dock and menu bar appears over the full screen video on the external monitor.

I've Googled and the only way I found to get rid of them is to uncheck the "Displays have separate Spaces" in System Preferences >> Mission Control.

However, that brings the unfortunate effect that when I switch to a different desktop than the one where I started the video, I lose the video on the external monitor as it too switches to a different desktop.

Anyone know how I can get rid of the menu bar/dock on the external monitor and still keep it as a separate space?

  • Have you tried making the video available on all desktops? IMO, the best solution I've found is to get a cheap tablet and use that to watch videos while I work. – Allan Dec 28 '17 at 15:02
1

Try setting your dock to autohide while leaving the displays with separate spaces. Also make your video playing app fullscreen before using the fullscreen feature built into the app.

This answer says that the menu bar cannot be hidden, but it shouldn't be showing up in full screen unless you place your mouse over the top of the second monitor.

  • The menu doesn't display if the app that's full screen is in the foreground, but switch to another app that's on another monitor, and it's not in the foreground anymore, so the menu appears. I changed setting as described in the question without that side effect, but what I really want to separate spaces without the menu appearing when I switch to the other window. The menu shouldn't appear when full screen even if that window is not the active one, imo. – Victor Engel Nov 12 '19 at 2:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .