8

I'm trying to access my MacBook from a Windows PC over the network. The computer is connected to the router, the MacBook is connected to a WAP, which is connected to a switch, which is connected to the router.

When I click on Network on the PC, the MacBook doesn't show up. It has done previously. Sometimes the Windows computer shows in the Finder sidebar and sometimes it doesn't.

How can I make the MacBook show in Network [Places] on the Windows machine? And how do I make the Windows machine stay in the Finder sidebar?

4 Answers 4

4

Another issue is you might not be in the same workgroup. To fix this go to

System Preferences -> Network -> Advanced -> WINS:

Make sure his Windows box is set the same. What OrangeBox suggested must be done as well.

workgroup setting

1
  • I was able to resolve the issue by taking the name given in the NetBIOS Name field above, open a run dialog with <kbd>![Windows Key][newwinlogo]</kbd>, and type \\ and then the NetBIOS Name (so in the above example the full path would be \\MACBOOKPRO-D04A)
    – Keyslinger
    Feb 14, 2021 at 3:17
4

In my experience there is no quickfix way to get windows and mac machines to always be visible in the others networks list.

The best thing you can do is enable Samba filesharing on your mac, then when you want to connect you just type smb://Jonathan's MacBook Pro into the address bar in Explorer (or into the run dialogue).

To Enable SMB sharing on your Mac:

  1. Go to System Preferences > Sharing > File Sharing
  2. Select Options
  3. Tick Share files and folders using SMB (Windows)

This has always worked for me with networking windows machines in Mac environments.

1
  • 3
    `smb:\` results in a pop-up telling me that I'll "need a new app to open smb" but Windows can't seem to figure out what it would be.
    – Michael
    Mar 31, 2018 at 0:32
2

I was able to resolve the issue by copying the name given in the NetBIOS Name field in the answer given by rubixibuc and pasting it into a run dialog, typing \\ and then the NetBIOS Name (so in rubixibuc's example the full path would be \\MACBOOKPRO-D04A)

To open the Run dialog, simply type Windows key+R

Run dialog

1
  • This worked for me, but I also needed to enter a username and password. You can just use the same username and password that you use to log in to your Mac, but you need to type the username as MACBOOKPRO-D04A\Username where MACBOOKPRO-D04A is your Mac's NetBIOS Name. Jul 22, 2021 at 12:30
1

Try changing the workgroup name from the iMac and windows PC. I have same problem and after I change the workgroup name it work. Try to ping your iMac check if the connectivity is good. Start - run - cmd - ping and the IP address of your Mac.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .