12

I have AirPods and I love them but I don’t love what a hassle it is to switch my phone to send audio output to the AirPods. I have my AirPods synced with multiple devices such as my Mac, so it doesn't know which one to connect to.

What I do now is:

  1. Swipe up from the bottom edge to raise the control center.
  2. Force press the wave icon in the top right of the audio playback control
  3. Tap the audio out control button on the right to raise a list of output devices.
  4. Select the AirPods from that list.

This is too hard. There must be a simpler way. Is there?

For instance, can I configure a single tap control center button to switch to airpods? Tell Siri to do it with a properly phrased command?

2
  • 2
    agree that this is an issue. seems to try connecting to device it was last paired with. I follow the same technique when trying to pair which proves frustrating sometimes when answering a call. Obviously sometimes the AirPods come up easily during a call/music etc. but not always. and sometimes the pairing process takes time. I've learned to live with it. I do like your control center idea. It should only take two actions instead of 3 (as we do now). Also I wish Siri could take commands like "Play Jazz on Kitchen Speakers" or "Call Mom on AirPods"...one day – JBallin Dec 28 '17 at 20:33
  • 1
    Just want to note that you don't seem to have to force/3d push on the wave icon. On my iPhone 6 (no force/3d touchscreen) I can get to the output options just fine by tapping the "signal" wave lines in the corner of the audio block. Thanks so much for this option! Previously I was using the damn Bluetooth preferences, which is a nightmare to get into (and of course involved unlocking the phone too!) – jerclarke Dec 10 '18 at 16:54
4

Just because one device sleeps does not make the airpods sync with another device. In such a case nothing happens and you have to manually connect on the device of your choice. I also struggle with this. My devices are not equal and I do different things on my iPhone, iPad, Macbook and iMac. What would be perfect, as mentioned, is a Siri integration. But that would mean that the Airpods understand Siri, which they don't. Thanks for the tip to go via the media control, far less hassle but not ideal.

1
  • +1 ironically OP's question offered me a better way to do it than I did before (opening bluetooth preferences, which is a nightmare). Hopefully they add a better way sometime soon. Tragically "you can't use it to connect to bluetooth" was a specific limitation of the Shortcuts system in iOS 12, so that is a dead end too. – jerclarke Dec 10 '18 at 16:50
3

I came across your post while looking for a solution to the same problem. In the meantime, it's possible to at least reduce your 4-step process to a 3-stepper, assuming you're starting from the home screen, although it does require keeping the settings app in your device's dock area:

  1. Force press the "Settings" app icon
  2. Select "Bluetooth", conveniently located on the last (i.e., nearest) row of choices.
  3. Select AirPods from the list of Bluetooth devices.
1
  • Good to know. Just commenting to note that this doesn't work on older phones without force/3d touchscreens. The other solution from the control center does though, and doesn't seem to require a force/3d touch. – jerclarke Dec 10 '18 at 16:53
2

AirPods automatically connect and enable themselves as the audio output when taken out of the case and placed in your ears.

The audio output is switched back to the phone when AirPods are placed back in the case. You should rarely need to manually set the output device.

If you do need to manually set the output, you can 3D Touch anywhere on the media control, not just the wave icon in the corner.

5
  • 2
    Almost every day, I use my AirPods on my iPhone, my iPad, and on my Mac. The AirPods themselves cannot guess which device I am using. That's why I'm constantly setting them as the audio output on the device itself. – algal Dec 28 '17 at 19:25
  • @algal Ah, the other devices wasn't mentioned! The last paragraph is still relevant, plus isn't your Mac sleeping when you're using your iPhone so your AirPods jump there anyway when placed in ears, and similar when your iPhone is sleep? – grg Dec 28 '17 at 23:16
  • 2
    I have a ridiculous life where I’ll have an iPhone, a Mac, and sometimes an iPad running simultaneously, so my AirPods rarely have the chance to fall back to the desired device. But it’s good to know that they try to do that when possible. – algal Dec 29 '17 at 3:05
  • Answer does completely ignore the poster that already writes that the issue is the changing between devices. These additional facts of automatic switching when one device sleeps are very interesting though, should be added to answer (but seem to be incorrect, see next answer) – K.-Michael Aye May 24 '18 at 20:23
  • Make sure all devices are actively signed in and have the same Apple ID. If so make sure Bluetooth is on as well. They should auto switch when placed in your ears. They are connected to your Apple ID so all of your devices should be able to recognize them. – Melvin Jefferson Jul 18 '18 at 22:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .