1

I'm cutting and pasting from Apple's Community support site where I posted this issue today, rather than type it again, since the details are dense:

My system, prior to 12/20/2017 was a MacBookPro9.2 (mid 2012) running 10.8.5. Why that OS? I hate Apple upgrades, as things always break and 3rd party SW has to be upgraded. Mountain Lion is a perfectly good OS, but over time has not been able to keep up with iOS. I loath the Apple phone so 10.8.5 suited me just fine, until I needed some R bits complied for Sierra. So, R is very important to me so I upgraded to 10.13.2 from the Apple store. I upgraded to an SSD inside the Mac, and after 5 days of testing, used Carbon Copy Cloner 5.0.5 to clone the SSD to an HFS+ (recommended by CCC) HDD inside an OWC/Mac.Sales On-The-Go USB 3.0 enclosure. No issues and CCC even created a 10.13.2 Recovery image. Interestingly, the Apple store upgrade wiped the 10.8.2 Recovery image on the SSD, leaving me with no Recovery image on that drive.

The HDD inside that enclosure is not bootable, neither the standard image nor the Recovery image though it is readable. The boot-time progress bar goes about 60% of the way and then aborts to the circle with the diagonal line. Bummer! After several days of troubleshooting with a CCC support engineer, with zero success, I was left with no option other than to swap the SSD and the HDD to nail down whether it was the enclosure or CCC at fault. Now folks, get this, the HDD when inside the machine boots perfectly, both standard and Recovery images but when the SSD, which received the bits from the Apple store, is inside the OWC enclosure, it will not boot. Also interestingly, the problem is not bidirectional. CCC can write to a disk inside this enclosure and create a perfect OS image, but the error occurs at boot time when the bits are being read. Man, does that make me suspicious. Did Apple do this to harm competitive device makers or is 10.13.2 still flaky? I've reported the issue to OWC but have yet to hear back.

So, other than buying a new external enclosure guaranteed to work with High Sierra, is there any fix to make the OS boot from an external device? Has this issue been seen by others? Also, bummer twice over, I have a RAID backup device still at 10.8.5, bootable, to which I fear attempting a backup, since that image could also be made unbootable :-(

  • Welcome to Ask Different! :) I appreciate the reasons for you copying and pasting this from the discussion you started at Apple's Communities site, but I strongly suggest you edit your question to remove a lot of the extra info that, as far as I can tell, is actually irrelevant to the question you're asking. This will make it easier to follow and more likely to encourage answers from the community. Reading how to ask a question may also be useful. All the best with it! :) – Monomeeth Dec 28 '17 at 0:23
3

Assuming I read your question correctly, on the face of it it seems the issue is with the enclosure since neither the HDD nor the SSD will boot when inside it.

However, two things you could try (because they're simple and quick to do) are to reset both the NVRAM and SMC, in that order. Before following the steps below, ensure you have no external hardware connected (so, unplug your external enclosure) and make sure you use the built-in keyboard.

Reset the NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM). Here’s how to reset the NVRAM on your particular MBP:

  1. Shut down your MBP. That's a full shut down, not just logging out.
  2. Press the power button and then press the commandoptionpr keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. speaker volume, screen resolution, startup disk selection, time zone information, etc).

Reset the SMC

To reset the SMC on your particular MBP, follow these steps:

  1. Shut down your computer
  2. Keep the power cable plugged in.
  3. Press at the same time shiftoptioncontrol (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

After resetting both the NVRAM and SMC, test your Mac to see whether you can boot from the external enclosure.

| improve this answer | |
  • Thanks, I'll try that but I don't believe editing the post is necessary or desirable. The details are important background. That USB enclosure has been working perfectly for five years and now is hosed because of High Sierra. The issue is 10.13.2, not the enclosure, although I strongly believe Apple upgrade broke the enclosure. – perlboy Dec 28 '17 at 1:13
2

Test your RAM with memtester. Also if you upgraded your RAM with non Apple modules, if you still have the originals try to swap them back and see if the problems keep showing up.

| improve this answer | |
  • How will this help - the OP is having trouble with external disks – mmmmmm Jul 17 '18 at 17:05
  • A couple years back I couldn’t boot off external drives and the problem was that my ram modules were getting bad. Replaced them and all the problems went away. – felix.v Jul 17 '18 at 17:47
0

I have functionally the exact same problem. Dual-boot internal SSD with Mountain Lion 10.8.5 and High Sierra 10.13.6 in a 2012 MacBook Pro (non-Retina). Both systems and both Recovery HDs boot fine. All are cloned to external HD in a USB 3.0 case.

External 10.8.5 and its Recovery HD boot fine. External 10.13.6 and its Recovery HD will not boot when chosen in Startup Disk control panel. On Restart, MBP bizarrely boots into external Recovery HD (10.8.5), not external 10.13.6.

On regular startup holding down Option key, external 10.13.6 and its Recovery HD do not even appear in list. All 6 other bootable partitions do.

Resetting NVRAM and SMC, as described above, had no affect on issue. I have exhausted all partition, directory, and file tests. External 10.13.6 is a perfect clone of functioning internal 10.13.6.

This is a serious bug and I need a resolution. My external HD is a 15mm height 4TB, so I cannot just open the MBP and swap the 4TB 7mm height SSD with it. The MBP will not accept a 2.5" drive thicker than 9.5mm.

Carbon Copy Cloner site lists 2012 MacBook Pros as being unable to access boot partitions beyond 2TB on an external drive. This seems to be my case. Did anyone ever find a solution?

| improve this answer | |
  • Welcome to Ask Different! This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – Tetsujin Jul 14 at 7:44
  • Hello Paul Palm, – perlboy Jul 15 at 19:36
  • This is update on my original post. I am now running macOS 10.13.6, and machine will still not boot from my On-The-Go USB 3.0 enclosure. The machine has been back to Apple twice, once under warranty, and once thereafter. Original memory and HDD were reinstalled, (Apple requirement). Both failures were the ethernet interface. Machine came back with same memory and HDD, so both passed depot diagnostics. No version of macOS I've tried will boot from that enclosure, but backups can be made to it. My conclusion: Apple won't update driver. Solution: Get a new enclosure vendor-guaranteed to boot. – perlboy Jul 15 at 19:50
0

Created my own solution last night.

Re-formatted external 4TB clean, then re-partitioned it with the first partition being 1.95TB and the second 2.05TB. From there I repeated the cloning of my two internal 2TB partitions to them. (Taking a cumulative 10 hours, that's no minor trial and error.)

Since the boot blocks of both systems reside within the first 2TB of the drive, everything works just fine now. As I made no other changes, the problem of a 2012 MacBook Pro not booting from an external hard drive where the system is beyond the first 2TB must be true. I imagine that an unlimited number of partitions could boot the same way, as long as they do not begin beyond the 2TB mark.

In hindsight, I should have made the 2 partitions 1.98TB and 2.02TB, which would have the second partition begin 20GB into the first 2TB. That's enough space for the whole default system folder. Perhaps even 1.99TB and 2.01TB would work.

That said, the problem was clearly not the RAM, PRAM, SMC, or external enclosure.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .