12

Since upgrading iOS to 11.2.1, my iPhone has aggressively prompted me to setup Apple Pay. Every time I decline to set it up.

Now, there is this persistent badge ("1") on my Settings app, which makes me think there is some kind of iOS update to install, but instead, it is a prompt to setup Apple Pay ("Finish Setting Up Your iPhone"):

How can I turn off prompts/notifications/badges asking me to setup Apple Pay?

This is not the same as disabling Apple Wallet notifications, as asked and answered at Disable Apple Pay/Wallet spam. Disabling Apple Wallet notifications does not disable the Apple Pay spam (specifically, the Settings badge icon). This question is different as it is about Apple Pay and the Settings badge icon (not notifications specifically), and the solution in the purported "duplicate" question does not solve this problem.

3
  • 1
    I wonder if this is a result of “Apple Pay Cash”....
    – Tyson
    Dec 27, 2017 at 18:31
  • 1
    lol despite the fact that you clearly explained the difference between our two questions, and mine was asked a year before yours, someone just marked mine as a duplicate of yours. Some people..... At any rate, I'm glad you asked about this, because that badge was annoying me too. Glad to have it fixed now.
    – Chase
    Jul 3, 2018 at 19:05
  • I can’t believe this is still happening Sep 27, 2021 at 1:18

4 Answers 4

10

Choose the option to finish setting up your iPhone, then choose Set Up Apple Pay. On the following screen, under Continue, choose Set Up Later in Wallet.

If you are in a region where Apple Pay Cash is supported, go to Wallet & Apple Pay in Settings, then disable Apple Pay Cash.

0
2
  1. Go to Settings app → Wallet and Apple Pay.

  2. Turn off Apple Cash.

  3. Go back to Settings app main screen and go to the notification about setting up Apple Pay. Click as if you’re going to set it up, and then click on set up later.

  4. You then have to go back into "Wallet and Apple Pay" and again turn Apple Cash back off as it was turned back on.

2

It is because of Apple Pay Cash. When the feature is enabled, you need a valid card in order to use Messages (since that’s the vehicle for Apple Pay Cash). If you go to the Wallet settings, it will say this pretty explicitly. When you turn off Apple Pay Cash from that screen, the nag immediately disappears.

enter image description here

At least it did for me. I had previously already clicked the “set up later” link in Apple Pay setup. I don’t know if that was necessary or not.

5
  • There is no "Apple Cash" switch in Wallet & Apple Pay on iOS 14.6. Care to attach an image? Aug 11, 2021 at 7:07
  • It's still there (confirmed on an iPhone 7 running iOS 14.7), right at the top of the screen. See also support.apple.com/guide/iphone/use-apple-cash-iph385cf0980/14.0/…
    – David C.
    Aug 12, 2021 at 16:32
  • Says US Only in that support page. I have just a single slider on Wallet and Apple Pay for double tap of side button activating a card. No other controls beside that and a link to add a cc. Aug 17, 2021 at 9:27
  • I just uploaded an image of the page on my phone. It's iOS 12, but I've seen the same setting on a phone running 14.7. I assume you don't have it because Apple Pay Cash is US only and you're not in the US. If iOS is trying to get you to configure it anyway (via the nag indicator on the settings icon), then it sounds like a bug.
    – David C.
    Aug 17, 2021 at 20:43
  • 1
    My screen is like yours minus the Apple Cash switch: anyhow the nagging has magically stopped (for now?) Aug 18, 2021 at 7:46
0

I got round it by adding a card I never use and not verifying the card. Not ideal but it works

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .