5

I'm having issues formatting a micro sd card a for a friend on my Mac. I've tried using Disk Utility, diskutil commands in terminal and SD Card Formatter. This is what I get when I try on terminal:

jonathandiller$ diskutil unmountDisk /dev/disk2
Unmount of all volumes on disk2 was successful
jonathandiller$ sudo diskutil eraseDisk FAT32 NONAME MBRFormat /dev/disk2
Started erase on disk2
Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk2s1 as MS-DOS (FAT32) with name NONAME
Error: -69830: This operation requires an unmounted disk
2

In the half-dozen or so instances where I've seen this specific error, the micro SD card itself had gone bad and couldn't be formatted on Mac, Windows or Android (via OTG), even with different card readers. Not only couldn't the card be formatted, but files couldn't be added or deleted nor anything else that required writing to the card. (Reading files was unaffected.) It was effectively in read-only mode like a full-size SD card with the switch flipped, but obviously the micro SD doesn't have that. Only solution is replacement.

I know this is an old post, but I thought I'd add the real cause (i.e. a defective card, not a software or format issue) for future reference.

  • I was never able to recover the card but I was able to recover the files using a tool on Ubuntu. I don't remember now what the tool was, but there are several other posts that discuss this topic. – Jonathan Oct 4 '18 at 2:37
2

FAT32 cannot format partitions bigger than 32GB. You will have to use a different partition scheme that is compatible with whatever device this SD card will go into, like exFAT.

  • I tried using exFAT and still got the same error: Error: -69830: This operation requires an unmounted disk – Jonathan Dec 27 '17 at 17:41
  • @JonathanDiller Have you unmounted the partition but left the card attached? – drivec Dec 27 '17 at 17:57
  • I left the card in but unmounted it using the unmountDisk command. – Jonathan Dec 27 '17 at 18:15
  • Are you able to perform any kind of partitioning on any card in the SD slot? I had a similar problem once, turned out some hardware cable had either been broken or disconnected.. repair was to expensive so I am by now unable to perform any such actions on cards in my SD slot. – Montmons Jan 12 '18 at 22:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .