1

I am new to Mac OS X. I need some help. I am having the following setup.

  • Yosemite 10.10.5
  • Python 2 Version 2.7.13
  • Python 3 Version 3.6.2

I downloaded the python-3.6.2-macosx10.6.pkg and installed it. It is under the folder

/Library/Frameworks/Python.framework/Versions/3.6/bin/python3

When launching the IDLE application in the “Python 3.6” folder under applications folder the following error happens

Python 3.6.2 (v3.6.2:5fd33b5926, Jul 16 2017, 20:11:06) 
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
Type "copyright", "credits" or "license()" for more information.
>>> WARNING: The version of Tcl/Tk (8.5.9) in use may be unstable.
Visit http://www.python.org/download/mac/tcltk/ for current information.

I would like to get the IDLE application working with a Python 3.6.x interpreter.

In order to correct the problem we are asked to

  • Install the latest 8.5 ActiveTcl version.
  • Reinstall python 3

What is the recommended way to do the above?

  • Do I uninstall the existing Python 3 interpreter? Then install the latest 8.5 ActiveTcl version. Then install Python 3 again.
  • Do I install 8.5 ActiveTcl version. Use make altinstall to build a new version of Python
  • Is there any other way to achieve it?
  • have you tried running idle3? – jmh Dec 26 '17 at 17:36
  • I get the same message but idle3 runs fine. – jmh Dec 26 '17 at 17:37
  • Sorry, about the long delay in getting replying. I got the same error when I used the "idle3" command. But I hit enter in the Python shell window and I got a fresh Python prompt. I was able to enter a small program in the text editing window and run the program, Thanks a ton!!! – MJay Mar 28 '18 at 9:10

You must log in to answer this question.

Browse other questions tagged .