2

I am using iTunes on Windows 10.

There are multiple "copies" (air quotes) of most (not all) audiobooks in iTunes. I used air quotes because when I search the PC for the books, there are only single instances.

Another post (Why does iTunes create multiple exact copies of my music files and hide them from view in Finder?) asked a similar question about music files. The answer for that post alluded to a playlist problem.

But (a) I do NOT have any playlists for my audiobooks, and (b) that post is old, dating to Sept. 2012. I am running version 12.7.2.

When I select a copy of a book and drag it to my iphone, I can see that the copies are numbered 1, 2, 3, ...

When I try to delete any one of those copies, then all copies are deleted.

What can I do clean up the lists so that I only see one copy of the book?

5

Through trial and error, found the source of the problem and a solution that consistently works for me. Explanation and screenshot follows.

Source of the Problem

The Sorting tab has three groups you can sort on: title, chapter, author. If the text in the specific field is disabled, then there will be duplicate copies of a given audiobook.

Note: The words "disabled" (for gray text) and "enabled" (for black text) in this context are my own and may or may not be the same terms used by Apple devos.

Solution

Simply retype the disabled (gray) text.

The screenshot shows an example where the "chapter" field was disabled. When I retyped "Mixed," the text changed to black. Clicked OK, and the duplicate audiobooks disappeared.

The same solution worked for me when title or author were disabled. Note that the "sort as" field is ok in gray.

Troubleshoot duplicate audiobooks

5
  • 1
    Thanks for this. This was extremely frustrating for me and your solutions seems to work! – user286871 Apr 26 '18 at 4:05
  • 2
    This solution would rename all the chapters to "Mixed". – Beggarman Sep 17 '19 at 15:17
  • @Beggarman - Good point regarding editing a disabled "chapter" field and whether seeing "Mixed" for all chapters is bothersome for someone (it's not for me). Presumably NOT a problem when editing a "title" or the "author" field? Maybe the solution to avoiding "Mixed" for all chapters is in the next answer from sgk and edited by Allen. Haven't loaded a book in awhile but will that answer a try when I do. – RJo Sep 18 '19 at 17:08
  • @RJo it's not a problem with Title or Author because those are usually the same for the entire book whereas each chapter has a different label. What worked for me in the end was adding the book title to the start of the chapter names. In the example book shown I'd label the first chapter Golden Age - Chapter 1. Since I started doing that sorting hasn't been an issue. – Beggarman Oct 23 '19 at 20:36
  • Similar to @Beggarman all my chapters were renamed to "Mixed". Alternatively, an easy way to get rid of duplicate albums in your audiobook library grid view is to sort "as Author by Author", which sounds a bit ridiculous but it works. – Kidquick Jun 12 '20 at 11:14
0

This works like a charm.

  1. switch to grid view in View > View as
  2. Select all chapters of the offending book
  3. follow solution above

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .