5

After unplugging/rebooting/waking, regardless of whether the power cord is plugged in, the screen on my MBP (15-inch, 2017, MacOS 10.13.2 [17C88]) will default to a brightness around 80%. Is there any way I can disable this, or at least change the default to something brighter?

1

That's not a standard macOS feature nor a feature of the laptop. Perhaps something's wrong with the SMC? Display backlight problems can be indicative of an SMC error.

The display backlight doesn't respond correctly to ambient light changes.

You can reset the SMC. Shut down your Mac, then…

After your Mac shuts down, press Shift-Control-Option on the left side of the built-in keyboard, then press the power button at the same time. Hold these keys and the power button for 10 seconds.

https://support.apple.com/kb/HT201295

The dimming when unplugging power can be controlled in System Preferences → Energy Saver → Battery:

enter image description here

  • I am having this problem, too. It is easily reproducible, and you can even see it happen in the prefs pane for displays. Ensure laptop is plugged in. 1) open prefs pane for displays; 2) adjust brightness to 100%; 3) unplug laptop -- observe that the brightness slider drops to 75% or so; 4) plug laptop back in -- observe that brightness only goes up to about 80%. This is really very annoying as i like the screen at full brightness, always – JDS Feb 21 '18 at 16:06
  • @JDS That's something else which can be resolved easily, see edit! – grg Feb 21 '18 at 19:02
  • I don't mind that it dims when I unplug, and I know about that setting. I mind that it doesn't return to 100% when I plug back in. – JDS Feb 22 '18 at 17:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .