5

I’m trying during the installation from MacOS High Sierra to separate the system and user data. I splitted the SSD with Disk Utility, but I can’t mount the second APFS Volume to /Users with the Disk Utility. Is that possible at this stage?

6

Not with Disk Utility (can't specify custom mount points with Disk Utility) but the macOS installer environment has Terminal. With Terminal, you can run:

mount_apfs /dev/disk1s3 /Users

Replace disk1s3 with the identifier of the volume to mount there.

This should answer your question about mounting during installation, but after a reboot your disk will be unmounted and /Users unavailable. To permanently set a mount point, you'll have to mess with fstab.

2
  • Thanks a lot @grgarside! I tried it today. I added a volume Users then I went into the terminal mount_apfs /dev/disk1s5 /Users and I got the following error message: /Users: No such file or directory. I tried to create the folder with mkdir Users' but I got this error message: Users: Read-only file system`. – stevo Dec 28 '17 at 0:51
  • @stevo I guess you’re running that from Terminal in recovery/install environment? In that case, you need to specify your disk: /Volumes/Macintosh\ HD/Users instead of /Users for example – grg Dec 28 '17 at 8:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .