So my MacBook Pro has been experiencing some weird issues after an unprompted and unexpected shut down. When I turned it back on, it claimed there was a “critical software update” and asked to choose a WiFi network. So I did so and it installed and after two minutes it was done. However, the USB C ports on the left side had stopped working. I was using a satechi adapter and removed it to find that the charging cable only works on one of the two ports now. The right side ports will work with the adapter usually. I did a SMC reset and reinstalled High Sierra, so before I do a full wipe I want to see if anyone can give me an answer.for reference this is what it looks like,  please ignore the network names, I can’t cnesor the on mobile

  • After reinstalling macOS the problem wasn't solved? Have you run Apple Diagnostics?
    – JMY1000
    Dec 22, 2017 at 5:33
  • The problem wasn't solved by reinstalling the OS. By Apple Diagnostics do you mean Disk Utility or something else? EDIT: I did a google search, I'll have to try that. Dec 22, 2017 at 5:35
  • No, here.
    – JMY1000
    Dec 22, 2017 at 5:37
  • Just used it, it found no problems. It booted into recovery mode fine but the adapter on the right (working) side seems to not work. Recovery mode then froze when I tried to restart, causing me to have to forcibly shut it down. Dec 22, 2017 at 5:45
  • Wipe it. If that doesn't work, Apple Store. This really is weird.
    – JMY1000
    Dec 22, 2017 at 16:12

12 Answers 12


Weird enough I just had this, I unplugged all the USB-C devices and then did a power cycle and it booted fine. I think it's time to build a backup computer.


I solved this by using my mobile hotspot - for some reason my office/home wifi kept going in a loop. Might be worth a try?

  • We are looking for answers explaining what you did to solve the problem so others, which may have less experience, can reproduce those steps. Can you edit your question to add more details?
    – nohillside
    Oct 8, 2018 at 18:30

I had a similar solution. At home i had that Problem. Via WiFi and LAN Cable. at the office it just worked at the first try.


Uninstall Hands Off! in Safe Mode boot and reboot Mac.

  • 3
    What does that even mean?
    – Allan
    Nov 26, 2018 at 11:25
  • Sounds like a sensible answer, Hands Off! installs a kernel-level network extension to control network access that is likely interfering with this Setup Assistant step requiring network access.
    – grg
    Nov 26, 2018 at 17:15

Happened to me recently. It could be related to a hardware/firmware issue with the touchbar. Resetting the NVRAM (holding down CommandOptionPR at boot up) seemed to help. The problem has not reoccured since then (4 days ago)


Some generic “fixes” like nvram/pram reset won’t solve or help for this issue.

Full clean install, installation on top of existing only fixes this half way. If you want to avoid a reinstall - try this workaround:

ctrl+alt+shift+power to turn off the device Connect your macbook to the network WIRED with usbC->ethernet or usbC->thunderbolt,thunderbolt->erhernet, just like me

Turn the device on. The boot takes longer but it boots!

I did this 10 times to reproduce every time with the following results:

disconnected wired network, restart == critical update loop

power down with key combination, connect wired network, power on == booting

I have no persistent remedy for this issue. Everyone please try this, and edit this to be more clear if there’s a workable and repeatable solution here.

p.s. This workaround seems not to work on encrypted machines.

I just now figured some weird plist files inside /Library/LaunchDaemons/

Actually a script of my own... Anyways it seemd to block the embeddedOS activation. When moving it to the LaunchAgents it boots fine now.

  • Does your machine have a USB failure as well? This question is probably quite specific since it has a hardware failure - that could be causing all the symptoms.
    – bmike
    Sep 22, 2018 at 17:14
  • Hi bmike, afaik this critical update is for the WatchOS on your EFI partition, which is used to boot the touchbar. This WatchOS is jailbroken long time ago and slowly we see this critical update popup randomly everywhere. For myself, this issue is still not solved but I get out of this 'loop'. My machine is 100% fine. Even a full diagnostics scan (which takes 90minutes) shows no issues. Still has the same symptons.
    – unkn0wnDnS
    Sep 23, 2018 at 6:38

Have had this the past few days and have some information which may be of use here - Programs like 'Hands Off' and 'Little Snitch' (essentially ingoing/outgoing network traffic blockers/gatekeepers) were the cause of this not installing for me - if this happens, then boot into safe mode (Hold down shift when turning on) and disable the program, then restart and install.

As a side, conversations with apple advised that these updates are to do with the OS that runs the touchbar (among other things) therefore, if you can get into safe mode, this should confirm its not a hardware issue.


Weird, Tried every combination except full reset...

Tried to connect it through a MIFI device using USB-C converter... System restarted with an exception BSOD ... restarted and It worked OK...


I had the same problem, and I later got to find out a security update that failed to download completely because my WiFi went off was the cause. I connected to a different network and voila!


Having the same problem, it passed the critical update screen after several retries. Running diagnostics also does not show any problem.


So today I had another look at the laptop with this looping issue. Having tried nearly anything else I decided to replace the display. THE LAPTOP NOW WORKS FLAWLESSLY!

Booted to the OS without issue. When I installed the original display the problem re-occured. With a new display the touch bar is working fine, MRI passed, touch bar diags passed and the unit is booting and rebooting without any critical update requirement.


  1. Try to replace the whole top case with Touch Bar assembly.
  2. Try to replace the LCD.
  3. Should pass the critical update, but if it's not working, there might be some problem with the logic board.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .