3

When I hit Return after entering a number in a cell, the cursor automatically drops down to the next row under the cell. How can I disable that, so it stays on the cell I entered and I can move on my own to wherever I want to make my next entry? I use the num pad when entering into a spreadsheet and it is habitual to hit "enter" after inputting numbers into a cell, then arrowing to wherever I need to go next (often to the next column rather than the next row.) There was a way to disable the automatic movement in Excel, but I've not been able to find a way to disable in Numbers.

2

Not exactly what you've asked for, but try pressing Command+Return while the cell is still in edit mode, instead of just Return. This should keep the same cell selected.

Edit after OP clarification:

There is no option to disable cursor movement on Enter in the latest version of Numbers. It used to be there in earlier versions (pre 3.0, I believe).

  • That adds another line in the cell (a carriage return) nice tip, though. – bjbk Dec 21 '17 at 22:15
  • @bjbk are you sure? I've just opened Numbers to double-check, and carriage return in cell is done by Alt+Return or Ctrl+Return. – Andrii Stashko Dec 21 '17 at 22:38
  • Sorry, right. But command return goes to the parent. (Selects the table) – bjbk Dec 21 '17 at 22:42
  • I believe, a table is selected, if you were not editing a cell, but just had it selected (no cursor blinking inside a cell). However, in a cell edit mode, Cmd+Return ends editing and keeps that cell selected, as I said before. At least that's what my version of Numbers does, and what Apple Support says :) (Stop editing the cell and select the cell: Command-Return; Stop editing the cell and select the table: Command-Return twice; ) – Andrii Stashko Dec 21 '17 at 22:57
  • Excellent. Mine was selecting the table. I must not have been in edit mode. Good one! – bjbk Dec 21 '17 at 23:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .