5

Hope anyone might have an idea how to troubleshoot this problem:

Since I updated my MacBook Air 6,2 (early 2014) to macOS 10.13.2 both Night Shift and Flux have completely stopped working. Meaning no matter how often I start or restart or (re-)install Flux (or change any of the settings), or no matter how often I change the Night Shift switch, I am not getting any kind of red shift whatsoever anymore.. Both used to work fine before.

I've found a lot of discussions online regarding similar problems but all seem to boil down to either:

  1. Too old hardware, which shouldn't be the case for a 2014 MacBook Air.
  2. Deleting ~/Library/Application Support/com.apple.backgroundtaskmanagementagent/backgrounditems.btm as discussed here.

I tried the solution mentioned by point 2 but unfortunately it didn't do anything for me.

Does anyone know a way to pinpoint more closely what might be the cause of this problem?

2

Go to the 'Display' tab and check the 'Scaled' option instead of 'Default for display' (or vice-versa). Then, simply select whichever text option fits you better.

Once you select one, the display will reset automatically and you'll be having the correct display profile along with Night Shift working again.

Added the solution to Apple forums as well.

1

In my case, simply restarting my computer fixed this issue. Both F.lux and the Invert Screen option that I sometimes use at night (part of Accessibility features) were not working after upgrading to High Sierra. So, I suspected this issue was larger than just F.lux. I initially opened the above path but that led to an empty folder (there was no backgrounditems.btm file). As the suggestion involves both deleting backgrounditems.btm and restarting, I opted to see if maybe the latter would suffice and it did. In case it's helpful, I'm on a MacBook Pro (Retina, 15-inch, Late 2013).


UPDATE: F.lux and Invert Screen still work but now every time I connect or disconnect my laptop to an external LED Cinema Display or projector, the invert screen option gets triggered and must be manually un-inverted. Not a big deal but clearly a bug in High Sierra.

  • Tried it. Multiple times. Didn't do anything unfortunately.. still neither F.lux nor Night Shift are working.. – Montmons Dec 28 '17 at 6:48
0

I had to do 2 things to get Night Shift working (macOS 10.13.6):

  1. Make sure system services have location permissions enabled: System Preferences > Security & Privacy > bottom left corner, click the lock to unlock, enter password > Privacy tab > right pane, scroll to the bottom to System Services > click "details" button > check everything > done
  2. Turn on your WiFi: System Preferences > Network > highlight "WiFi" in left pane > click gear icon at the bottom of left pane > choose "Make Service Active" > right pane, choose "Turn WiFi On" > connect to a WiFi network

I found both of above was needed. I had disabled by WiFi adapter/service because I have my iMac hard wired with ethernet. It looks like MacOS needs the WiFi to find your location. I stumbled onto this when I was editing my time zone: System Preferences > Date & Time > Timezone > checked "set timezone automatically using location" and it had a message to enable WiFi to determine location.

As an aside item, you may want to re-order your adapter/services so ethernet is a higher priority than the WiFi so you utilize the fastest connection: System Preferences > Network > click gear icon at the bottom of left pane > choose "Set Service Order" > drag ethernet to the top of the list.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .