so I recently upgraded to High Sierra (formating the entire HDD of my MacBook Pro)

Everything worked alright for a week or two but two days ago browsers stopped working.

I usually use Firefox as my default browser but it started throwing some weird message I have never before seen so I uninstaled and open Safari trying to redonwload it. Open Safari and when I try to open google.com it just stay still "loading" the page.

No error code shown, no web content shown. Just there loading.

I suppose this is exactly what happened to Firefox...

The thing is: any other app using internet seems to work just fine and every other computer on my house is working just fine.
Just trying all the options I run MAMP and noticed not even the Localhost page is loading

Also tried starting in secure mode and plugging the ethernet cable and turning off wifi.

Any ideas on what can be the problem and/or how can it be solved?

Thanks a lot.

EDIT: I was able to download Chrome via Terminal and it is working just fine, I also realized that neither App Store nor Mail are working propperly, thanks

  • What was Firefox's error message? Can you take a screenshot of your network prefpane? What are the "any other app"s that you used to verify that the internet was working?
    – JMY1000
    Dec 20, 2017 at 5:47

1 Answer 1


I found a source of answer that addresses an issue very similar to yours on Apple Support Communities webpage.

Safari won't load after High Sierra upgrade

  1. Log out of your account.

    Click  menu in the menu bar > choose “Shut Down”.
    Then press the power button to start the Mac.

  2. Launch System Preferences.

    Look at the bottom of the pane.
    Do you see Trusteer Rapport or Tusteer Endpoint installed?
    If yes, click it and stop it
    or uninstall Trusteer Rapport/Endpoint.

  3. Do you have Airfoil app installed?

  4. Deselect Proxies, if selected.

    System Preference > Network > Advanced > Proxies Tab
    Unlock the lock if you have to.
    Under "Select Protocol", uncheck any box that is marked as check.
    Click "OK" then "Apply”.

  5. Sometimes third party software can cause this sort of problem.

    Please run EtreCheck and post the report here.
    Download it, open Downloads folder, click on it to open and select "Open".
    Select a problem from the “Choose a problem” popup menu box, and then “Start EtreCheck” in the dialog.
    Click “Share Report” button in the toolbar, select “Copy to Clipboard”, and then paste it when you reply.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .