2

I acquired a 13.3" MacBook Pro. The MacBook Pro turns on but freezes after approximately 30 seconds. I installed a good hard drive with Lion and the loading spinner simply stops spinning after it freezes. I also tried booting from a bootable flash drive but it also freezes. The boot media isn't compromised because I've used the hard drive and flash drive with different machines with success. I attempted resetting PRAM. The battery is brand new. I have also attempted verbose boot mode but it doesn't reveal anything abnormal.

Note: I have since allocated the hard drive to a different machine so I don't have a working hard drive available right now.

Though the bottom place indicates the model is 2010, verbose booting logged the CPU build date to be in 2011. Additionally, the interior hardware of the computer differs from 2010 models so I suspect the computer is a 2011 model.

What are your suggestions?

  • 2
    You can check the precise model on Ultimate Mac Lookup & get the appropriate Apple Hardware Test & instructions to boot from USB at github.com/upekkha/AppleHardwareTest – Tetsujin Dec 20 '17 at 7:22
  • @Tetsujin I'll try the hardware test ;) – www139 Dec 20 '17 at 17:07
  • @Tetsujin I attempted both the internet hardware test and the test off of a DVD. I see the interface for the DVD hardware test for just a moment before the computer abruptly shuts down. The internet hardware test fails with the message apple.com/support -3403D. – www139 Dec 20 '17 at 17:38
  • @Tetsujin Upon closer inspection, for a split second before it shuts down after loading the hardware test, I see the GUI with graphical glitches on the screen. I suspect it is a bad GPU. – www139 Dec 20 '17 at 18:06
  • the internet code looks like a connection fail. If it's bad GPU, then I'm out of ideas on how to test at consumer-level, sorry. I'd take it to a pro. – Tetsujin Dec 20 '17 at 18:08
1

If you had the hard drive still in the Mac I would have had you boot the mac into recovery mode and reinstall MacOs. It wont delete any information since its only rebuilding the system files.

You'll need to do the same when you get a working Hard Drive back into the Mac.

  • It freezes when going into recovery mode. It also sometimes gives a kernel panic. – www139 Dec 20 '17 at 3:46
  • Then you need to go into disk utility and do a first aid repair to scan the hard drive. – Melvin Jefferson Dec 20 '17 at 4:05
  • To be more specific, it was attempting to enter the recovery mode from a flash drive. The flash drive is good. I've used it on other machines. There is no hard drive installed. I just want it to load the recovery screen from the flash drive because it would be a good indicator that it would work from a hard drive. – www139 Dec 20 '17 at 6:50
  • Nope that hasn't worked for me. Mac OS detects that it is an USB drive. – Melvin Jefferson Dec 20 '17 at 7:02
  • 1
    What hasn't worked for you? I simply partitioned a flash drive and imaged the High Sierra installer. I use this as a recovery flash drive for Leopard, Snow Leopard, Lion, and High Sierra. I know it works. It should work and it has worked previously on other machines. The flash drive is less than three months old. There is no hard drive installed. It loads a portion of the installer from the flash drive before throwing a kernel panic (specifically with the Leopard installer though the High Sierra isn't much better as it never loads). – www139 Dec 20 '17 at 7:15
1

Physically remove the internal hard drive and try booting from an external one. If everything works fine then it's most likely your hard drive cable that needs to be replaced.

  • I don't have an external HDD to test right now. However, I've attempted testing from a bootable flash drive. I've attempted loading the Leopard installer and the High Sierra installer. The Leopard installer fails after ~3 seconds with a kernel panic. The kernel panic offers no error details but prompts to restart the computer. The High Sierra installer loads slightly past halfway and then stops. – www139 Dec 20 '17 at 17:03
  • Could be RAM also.. you could try removing one and retesting, than testing with the other. That might work out if 1 module only is defective. However without further tests and tools it's difficult to diagnose the problem. – Kevin Grabher Dec 21 '17 at 10:02
  • I've tried ~4 good SODIMMs in both/either slot. It seems the computer works perfectly for ~30 seconds before everything freezes. I was able to run Ubuntu Desktop from a flash drive perfectly for ~30 seconds before it froze. I was able to look at the system info panel long enough to determine it is actually a 2010 model. It may be the computer was a later revision which could explain my earlier confusion with identifying the model. – www139 Dec 21 '17 at 20:20
  • Can you disconnect the internal HDD and try installing a system onto an external one, see if that works? – Kevin Grabher Dec 21 '17 at 20:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .