1

I had very low disk space, but kept working because it has happened a number of times. Then I had to use Word, it behaved weird, forced a few restarts, and now if I resrart I get an apparently fine restart, except Finder seems to not open so I'm stuck with a gray screen and the cursor showing up. The computer seems to be working fine, except Finder apparently won't open. What can I do? Is there anything I can do except for restarting from a System CD-ROM (whivh btw may not work since my computer seems to have lost the ability to process CDs as I tried a couple different audio CDs and the reaction was the same: thinking for a long time, then spitting the CD out)? In particular, is there any way to auto-trigger the opening of an app with which I can browse the computer and back stuff up, like Terminal?

Extras

When I say the computer seems to work, I'm referring to the following facts:

  • Android File Transfer opens up when I connect my mobile;

  • Volume and Brightness regulations work;

  • Hitting any keys that would type something or an arrow key or esc elicits an error sound;

  • Caps Lock lights up when I press it;

  • Shift, fn, ctrl, Option and Command don't make sounds, and neither do the other F keys at the top of the keyboard;

  • The restart key toggles the usual dialog box, allowing me to sleep, shutdown, restart, or cancel;

Wish I could test eject but I have no CDs on my hands.

HW&SW info

I have a MacBook Pro with OSX 10.7 IIRC - can't verify because, well, "stuck on gray".

Update

Following @Tetsujin's suggestion, I restarted holding down Cmd+R, the screen went blue, light blue, and darker and non-uniform gray, and a language choice appeared. I chose English, and Mac OS X Utilities opened up. I opted for Disk Utility and verified the HD, which went fine, then the volume of my HD, and this has been stuck at "Checking catalog hierarchy" for the last minute or so, with the estimated time growing from 3 minutes to (as of now) 19 minutes. What could that mean?

Btw MacBook Pro confirmed, and the Utilities thing had an option to "install a new copy of Lion", so 10.7 confirmed, I guess.

Update 2

Verification ultimated about 3m ago, after turning to "extended attributes file" at 21m remaining.

Here is a "screenshot" of the Disk Utility:

Screenshot of Disk Utility

Update 3

Just restarted from the HD, and this told me my OS is 10.7.5. And I'm back at the beginning. What was I expecting? Dunno.

Update 4

Planning to try Target Disk Mode, computer now started up in said mode, required cable not at our disposal. We have lots of USB to external hard disk cables that are no good, a FireWire cable that must be an old version of FireWire cos it doesn't fit my FireWire port, and some ethernets which are no good for TD mode.

Update 5

Turns out we have a bootable hard drive. Using that as a "platform" to boot proved succesful, so I'm now moving stuff to my Time Machine and deleting it to free space. When these ~25GB are moved, I'll try using my Hard Disk to boot again, and update this with the results (as an answer if succesful, as an edit if not).

Update 6

Freed space, booted kinda succesfully, now stuck with:

enter image description here

That dialog box is completely unresponsive, just like Finder. The Force Quit Applications panel is blank. I mean, totally blank. Finder and Preview do NOT appear. The menu bar at screen tip won't appear even if I click where it should be. The rest seems to work just fine. What now?

Update 7

After a few restarts yesterday, thar annoying dialog box went away, and Finder started working again. Excspt today we're back there, and not only did Word not recover from the state it got to yesterday where upon opening I see the "opening dialog", and it stays there with the spinning ball of "not responding" while Error Reporting opens and quits unexpectedly, but now most apps in my doc (Word included) appear as folder icons and won't open. Three (iSkysoft Free Video Downloader, iMovie, and Inag Capture) have their icons covered by gray "forbidden signs" (you know, thick circles with thick diameters traced), and only Finder, System Preferences, iCal, Disk Utility, FaceTime, Safari, iTunes, Terminal, and Preview seem normal. Oh, and Audacity, Vuze, and HyperTranscribe have blank file icons instead of their own. Also, two Trackpad settings seem to use defaults even though they are set to the other value when I open SP: Tap to Click is checked but tapping doesn't click, and Scroll Direction: Natural is unchecked but behaves as though it were checked. That will probably be set straight by clicking the checkboxes twice, as I have done several times yesterday.

  • Knowing precisely what Mac & what OS would be a good start. – Tetsujin Dec 19 '17 at 11:32
  • @Tetsujin Good point. Added. – MickG Dec 19 '17 at 11:34
  • 1
    Everymac's Ultimate LookUp could probably hone down the precise model, but many early machines will only boot to a system CD, not USB. You could try holding Cmd/R at the chimes & see if yours will boot to Recovery. if so, you may have a few options. – Tetsujin Dec 19 '17 at 12:54
  • @Tetsujin (that is, Iron Man :) ) managed recovery mode, I guess. – MickG Dec 19 '17 at 13:25
  • 1
    Driving blind-folded for five minutes on a straight German autobahn with a car with excellent directional stability may be possible (at least at night), it's still not recommended! Safe & Single User Mode. Sleepimage and swapfiles are files which can be deleted safely (if deletable at all - I didn't test it). – klanomath Dec 19 '17 at 19:02

You must log in to answer this question.

Browse other questions tagged .