14

I am on a MacBook Air running macOS High Sierra 10.13.2 When I run xcode-select --install to re-install Xcode developer tools, I am prompted to this

enter image description here

I choose install option which opens the agree terms prompt

enter image description here

agree terms and this appears

enter image description here

and nothing happens for 30 mins, so I tried to stop and it didn't work, I tried the quit option from the dock which didn't work either. I had to force quit Install commandLine Developer Tools. Can anyone help me how to reinstall CommandLine Developer Tools. Thank you

18

I'd reboot the system and try again.

If that doesn't work, you can download it from Apple Developer.

If you don't have an Apple Developer Account, you can create a free account, and then once signed in you can download the "Command Line Tools (macOS 10.13) for Xcode 9.1" from: Downloads from Apple Developers

Downloads from Apple Developers

  • I ran this and ls -la /usr/bin | grep xcode still returns nothing – Ben Leggiero Mar 19 at 22:49
  • @Ben Leggiero, What explicitly and specifically do you mean by "I ran this"? You ran what!? Also, on my system in Terminal, which xcode-select returns /usr/bin/xcode-select. What version of OS X/macOS are you running? – user3439894 Mar 19 at 23:07
  • I downloaded "Command Line Tools (macOS 10.13) for Xcode 10.1.dmg" from the page "More Downloads for Apple Developers". I opened that DMG and it mounted and a Finder window appeared presenting its contents. I opened the file "Command Line Tools (macOS High Sierra version 10.13).pkg" contained therein. The installer opened an I ran that, ensuring I had the machine's main drive selected and accepting the user agreement. Several minutes later it succeeded, yet when I open Terminal.app and run ls -la /usr/bin | grep xcode andor which xcode-select no lines are printed. I'm on macOS 10.13.6 – Ben Leggiero Mar 20 at 0:49
  • @Ben Leggiero, The OP is the one that was having an issue with xcode-select and my answer primarily addressed how to install Command Line Tools for Xcode from Apple Developer site, so if you downloaded and install it... then why are you commenting on my answer? xcode-select is a part of macOS and is in the Core.pkg file of the macOS installer located in /usr/bin in the .pkg file. Why you do not have it on your system is not really the topic of the OP or this answer. I'd suggest posting your own question vs. a comment to an answer that really has nothing to do with its non-existence. – user3439894 Mar 20 at 1:13
  • Sorry for the confusion; I'll ask my own question – Ben Leggiero Mar 20 at 14:15
5

I had the same issue on macOS High Sierra. Not being a Mac enthusiast, I went online to find some answers, but found none.

I eventually figured it out (at least in my case, a MacBook Air running High Sierra). The window that states finding software actually had another window hidden behind it, with a prompt asking if I wanted to continue on battery power?

Installation happened right away afterwards.

  • 2
    Same thing happened for me... what a nightmare. – Scott Skiles Feb 11 at 23:09
  • Wow, and it wasn't even visible except on touchbar. Thank you so much! – Saurabh Shrivastava Jul 29 at 5:37
-1

In my case, it was just waiting for the charger to get connected. That is confusing; at least it can prompt for it.

Click on stop; you will be able to resume the download.

  • OP in the last para indicated that Stop didn't work. – ankiiiiiii Jul 3 at 6:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .