35

Sometimes it's hard to search for older versions of macOS & OS X on the App Store.

This is an attempt to provide the canonical QA for this issue, as per the Meta QA -
Where is the list of canonical questions stored for Ask Different?
I expect it to be modified over time to hopefully become a complete information resource.

How can I get any older version of a Mac OS to be able to run as a VM, or to reinstall on my Mac?

47

NEWS
October 2019
Because of the certificate issue Apple faced, which overnight obsoleted all the previous macOS installers, they have re-released several of these, with new certificates.

Apple KB - If an installer says it can't be verified or was signed with a certificate that has expired
This contains links to further KBs for each of the 6 most recent OSes from Catalina back to Yosemite.
The three newer ones link to the App Store, but Sierra, El Capitan & Yosemite link to direct downloads.

Note for those of us who like to keep all these for 'just in case'.
Download them one at a time & label them correctly before downloading another, so you know which is which. They are not identifiable from the dmg or installer name as to which OS they are :\
Worse… even when you run it, you get absolutely no indication of which OS it is going to install. Be careful.


The following would probably still apply if you were trying to access something older than Yosemite…

General Note
This task seems to be getting harder as time passes. A new wrinkle is that a lot of these older installers, even if you can get hold of them, have an 'expiry date'. The last widespread expiration date for many Mac installers was October 24, 2019 so you will need to re-download your installers after that date to keep them valid and signed.

If you see a message such as
“This copy of the Install OS X El Capitan application can’t be verified. It may have been corrupted or tampered with during downloading”,
or a more vague “An error occurred while preparing the installation. Try running again”
A new error seems to be…
No packages were eligible for install.

Try setting your clock to a date within a year of the OS's initial release date if you absolutely cannot re-download them.

From Michael Tsai's blog - Installing Old Versions of macOS

It seems that the installer is signed with a certificate that has expired. When booted from the installer, you can open Terminal and use the date command to set the clock to the past, i.e. to when that version of macOS was current. After installing, be sure to set the clock to the correct date, or various other things won’t work properly.


Since Mojave

[This section is still work in progress]
It would appear that in the new Mojave App Store, older purchased OS Installers no longer appear at all, so the 'simple method' of grabbing it from your purchase history is no longer valid.

Sierra, High Sierra & Mojave are available via direct links - see below.

Testing the El Capitan installer which has a published URL it will appear in the App Store, but if requested to download no longer says 'not valid for this Mac' it now says 'The requested version of macOS is not available'.

enter image description here

Some further testing is required - contributions welcome - to see if other OS versions are similarly removed. We may need direct links for these, which I don't have at present.

Additional note:-
I've attempted from VMs of older OSes to recreate the App Store as it used to be in El Capitan & High Sierra, to see if I could still access the old 'purchase history'.. with no success. The history appears as it used to, but I have been unable to access any older versions through it.
It seems you actually need a physical Mac running those older OSes to be able to reach back for those older versions.


For macOS versions since Sierra.

Sierra itself has now vanished from everybody's Purchase History. However, Apple are keeping Sierra fully available, even though High Sierra is out. No Apple ID is required.

High Sierra link tested from Mojave Jan 2019 - still works to download, though it does it via the new Software Update control panel. It won't run on a Mojave Mac but you have the installer in your Apps folder to move elsewhere


For OS X versions from Lion up to El Capitan.

I successfully re-tested this method Jan 2019 - still working as stated for a Mac limited to El Capitan. Purchased older OSes are still listed & accessible

The simplest way - if available to you - is to use your Purchase History on the App Store.
If you have ever previously installed any OS X version, it will still be available to you from that list. This should include any public beta versions too.

The version available from that list will always be the latest version of its type - i.e. 10.7.5, 10.8.6... 10.11.6

Image heavily modified to show only OS versions. enter image description here

Note, it will say Download or Install depending on whether or not you have the Installer file saved locally - even on a non-boot drive.


If the version you are trying to download is older than the Mac you are attempting to download it to - the Store will not allow the download.
[looking for workarounds to this part - edits welcome - I can't test this as the newest Mac I have is a 2012 Mac Pro]

Potential workarounds, need testing -
How to re-download Lion from Mountain Lion


For older Macs

If you are trying to update an older machine running Snow Leopard or Lion, then you can get a special version of El Capitan from the App Store

This version of El Capitan is for users running OS X Snow Leopard or OS X Lion who would like to upgrade to macOS High Sierra. If you are running Snow Leopard or Lion and would like to upgrade to High Sierra, you need to install El Capitan first. This version of El Capitan can also be installed on computers that are not compatible with High Sierra.

Note that last sentence... this version will not install on any machine that is not currently on Snow Leopard or Lion, if the machine is capable of running High Sierra.
That leaves it as quite a specific resource & not a general 'get out of jail free card' for anyone wanting El Capitan.

enter image description here


Recovery Options

If you need to reinstall from Recovery, & were previously running Sierra 10.12.4 or higher, there are now 3 options available.
Hold the appropriate key combo at the boot chimes...

  • Cmd ⌘ R
    reinstall the latest macOS that was installed on your Mac, without upgrading to a later version
  • Opt ⌥ Cmd ⌘ R
    upgrade to the latest macOS that is compatible with your Mac
  • Shift ⇧ Opt ⌥ Cmd ⌘ R
    reinstall the macOS that came with your Mac, or the version nearest to it that is still available.

The first 2 options are available to any Mac newer than Lion, approximately 2009.

There is also the option of creating a bootable USB of the Recovery Disk, using this Apple tool - Apple KB: OS X: About Recovery Disk Assistant


Should you have access to an older point release of any OS, 10.11.0 etc & wish to upgrade, then you can download Combo Updaters from Apple that contain everything necessary to go straight to the latest point release in a single step, e.g. 10.11.6

Google is good at finding these, as the top hit if you just search combo update 10.11 etc but here are links to a few

Mavericks 10.9.5
Yosemite 10.10.5
El Capitan 10.11.6
Sierra 10.12.6
High Sierra 10.13.6


If you need to create a bootable USB to install from

How do I make a bootable USB flash drive on a Mac?

How do I create a Mac bootable USB drive using Windows?


If none of these methods are available to you, you have two options

  1. Find a friend who can access the download [recommended]

  2. Find a torrent/sharing site [not recommended]

Additional Note:
There is no 'legitimate' way to download macOS from anything other than a Mac. It requires the Apple App store.


Note: You can not use a Time Machine backup to revert to an OS which is older than the OS of the latest backup on that Time Machine drive.

This means that to preserve your ability to ever restore to an earlier backup & OS with your Time Machine backup, you must swap out that Time Machine drive before upgrading the OS. This is because once the Time Machine drive sees the new OS, there's no going back to the older OS using it. You can still pick data out from the Time Machine manually, but cannot use it to restore to the older OS.

  • 2
    There seems to be a homebrew cli-interface for the MAS. I haven't had a chance to test it, but perhaps it would be able to download versions older than your mac. – Bruce Dec 20 '17 at 6:59
  • @Bruce - looks interesting - wonder if someone could test that & report back. I don't have a new-enough Mac here. – Tetsujin Dec 20 '17 at 14:59
  • So, it might just work for Mountain Lion. The cli-interface installs by product id and the installers for the OSes after 10.8 all have an id of 0. On the other hand, it seems like the Mountain Lion Installer is downloading to my MacBook (Early 2015). It's id is 537386512. – Bruce Dec 21 '17 at 2:36
  • 1
    @SkeletonBow - I don't know the precise moment at which it happens, & I always as a habit drop a new drive in just before a major OS update. I discovered this when I forgot that step when updating to Sierra & had a nightmare of a time trying to revert - apple.stackexchange.com/questions/271104/revert-to-el-capitan – Tetsujin Mar 13 '18 at 7:31
  • 1
    Thanks you very much @Tetsujin, I was on Lion and managed to upgrade to El Capitan thanks to your advice and link to the hidden OSX version on the Mac App Store, – nbaosullivan Jan 13 at 14:00
6

The Mac administrators community has open sourced a tool to help download OS installers using a python script. Even as Apple releases newer versions, this convenient script keeps getting updated:

installinstallmacos.py is the solution if you need several versions or just want to script parts of the amazing other answer to this question.

4

macOS 10.15 Catalina has a new feature in the ‘softwareupdate’ tool to download older versions of macOS:

--fetch-full-installer Install the latest macOS Installer
--full-installer-version The version of macOS to install. Ex: --full-installer-version 10.15

Some people have reported being able to download 10.14 using this feature in 10.15, however I was unable to reproduce this. In the future, this feature should allow you to choose older versions of macOS.

  • 1
    Nice find, unfortunately not something I can test, no Catalina capable Macs here. Do we know how far back that is intended to reach? Right back to 10.1, 10.6.8, or just 10.14? – Tetsujin Oct 16 at 8:32
0

If you're a registered developer (IMHO about the only reason to install an older version of macOS...flame me by e-mail if you must), you can go all the way back to 10.3.9 Panther.Apple Developer legacy library.

Please, please, please don't try to install a version of OS X that predates your machine; there may not be a way to get you back to the future. I strongly suggest running older versions exclusively in a virtualization host (i.e. Parallels, VMware Fusion or VirtualBox).

  • "Please, please, please don't try to install a version of OS X that predates your machine; there may not be a way to get you back to the future." Huh? That's not true at all—you can always boot from a USB, and usually do network recovery. Worse case scenario you need to find another machine to make the USB. – Wowfunhappy Nov 5 at 14:34
  • @Wowfunhappy sigh. Updating the OS also updates EFI and the recovery partition. With a bad/wrong EFI, you can’t boot or do network recovery. – Wilfred Smith Nov 5 at 22:06
  • If the EFI is wrong, the old OS just won't boot, and your new OS will still work. If you downgrade your EFI (which can be more difficult), all you'd need to do is upgrade your EFI again, which Apple does automatically. I've done all of these things a lot, and I'm not seeing a scenario where the user could unintentionally screw themselves. – Wowfunhappy Nov 5 at 22:26
  • BTW, other reasons non-developers might want or even need to downgrade: The new OS isn't compatible with a critical app or 3rd party driver; the new OS has a bug that critically breaks your workflow; the new OS performs poorly on your hardware. – Wowfunhappy Nov 5 at 22:33

You must log in to answer this question.

protected by bmike Oct 2 '18 at 4:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .