5

I am having difficulty repairing a Time Machine backup. After upgrading from Sierra to High Sierra, the Mac had difficulty finishing Time Machine backups to the Synology NAS. Ultimately the Mac itself would not reboot and the hard drive was wiped with Sierra reinstalled at the Genius Bar. (I was confident I had backups via the NAS). When I tried Migration Assistant I notice that the backup is "Amanda's Macbook Pro.purgeable".

enter image description here

The backup is encrypted (as I had set up.) I enter the encryption code and get the error "Some backups cannot be opened." Then I notice that it says there are "no volumes found in backup".

enter image description here

I then leave migration assistant and go into the backup folder on the NAS. I find the folder "Amanda's Macbook Pro.purgeable.sparsebundle".

enter image description here

In it there are a number of files and a very large "bands" folder.

enter image description here

The whole backup folder is 800+ GB which is about right for my MacBook Pro, so I know the information must be in there.

I make a copy of the entire backup folder to a separate drive so that I have a backup of the backup that is untouched.

I tried using the Terminal commands that many have outlined and had success with. I run into trouble halfway through this process.

after sudo su - I perform chflags -R nouchg on the sparsebundle folder which takes a little time and then completes.

After, I perform hdiutil attach -nomount -readwrite -noverify -noautofsck on the sparsebundle folder

enter image description here

Here is where it seems to deviate from everyone else's experience. Instead of the "GUID_partition_scheme" and "Apple_HFS", it only gives the disk name /dev/disk1

I run the fsck_hfs -drfy /dev/disk1 and even fsck_hfs -p /dev/disk1 and I get a very fast process (less than a second, rather than the several minutes to hours) and no mention of a volume being repaired or not repaired.

enter image description here

I unmount and try to use the backup but still cannot and it doesn't look like the folder was changed at all. I tried DiskWarrior on this as well (to a copy of the copy that I made to a second external HD) and still having issues.

Does anyone have any advice? I would appreciate any help! All of my children's photos are on this from the past 2 years and I would hate to lose them all.

Thanks!

  • Seems like you could be in for the worst here, but have you tried upgrading the computer to High Sierra then attempting to restore the backup again? I would also highly discourage doing anything to the backup without making a complete copy, as it's possible you cause irreversible harm. Given how important this data is to you, I might also suggest looking into data recovery if you can't fix the problem. – JMY1000 Dec 18 '17 at 5:57
  • Bryan, are you familiar with these commands or just running stuff based on what you're finding on the net? I am an advocate of messing around - safely, to learn, but this is on the border between intermediate and advanced stuff you're doing. Slow down, only work on copies of the sparsebundle, and try to understand what you're actually doing. Maybe the upgrade to High Sierra marked the backup as being purgeable because it needed to create a new one - but I'm not sure. I'd get Apple on the phone first - if you call, you can get access to techs that are more knowledgeable than in store. – Harv Dec 18 '17 at 7:09
  • Also copy off the .sparsebundle to a different Mac and see if you can open it. – Harv Dec 18 '17 at 7:10
  • Thanks for the advice. I have only been working on copies rather than the original. I will give Apple a call and see if they can help out. – Bryan Winn Dec 24 '17 at 4:27
  • Unfortunately, Apple said that they do not support the use of Time Machine with a NAS. I have sent a request to Synology but haven't heard back from them yet. – Bryan Winn Dec 28 '17 at 12:36
2

I got this error message when I tried to restore from my Synology. But I found this

http://thefunkstop.com/fix-corrupted-time-machine-backups/

Turns out that that the "Time Machine user" was never disconnected when my last backup was interrupted. I had to manually disconnect the user and then everything worked when I tried again. But I think it should work by restarting the NAS as well. I hope this can help...

1

Since Apple does support network file shares for time machine. I’d push the Synology support harder. You could also find someone to assist given how detailed your notes are - someone that does t ch work might be able to sit with you for an hour or so and collaborate and see if your backups are viable for a restore.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .