3

I have a Mac Mini (Late 2012) and a MacBook. About a week ago, I suspected that my Mini had been infected. So disconnected the Time Machine to preserve my backups, switched to the MacBook and when I had the time, downloaded the installer and tried to install High Sierra.

I created an external bootable media by downloading the installer on my MacBook, plugged in an external HDD and ran sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MacInstall

I got to the screen with the utilities, started Disk Utility and erased my Macintosh HD and replaced it with APFS. But of course, it's not a solid state drive, so that failed. I erased the disk again, and reformatted it as HPFS, journaled.

This time, I get 'an error occurred while preparing the installation. Try running this application again'.

I have downloaded the installer a second time, and tried again. Same result. I checked the date and it is correct. I even tried resetting the NVRAM. No luck. At this point, I have a Mac sitting here like a brick, that I can't use.

Can someone recommand how to get round this?

  • Great details - forgive the mostly standard error - be sure you pay very close attention - if HPFS is something you actually chose - there's something amiss. I'm guessing you have HFS+ and it's just a transcription error here. Since you have bootable media - see if you can find the install.log on it or try again and watch the logs. – bmike Dec 17 '17 at 15:53
2

The most likely error is that the disk isn't partitioned correctly. If you have a bootable installer or can connect it in target disk mode - try erasing the entire physical volume again.

enter image description here

In the image above - you want the top item selected and not the volume under the physical drive. I like to click erase and then not make any changes from the defaults - leave the name Untitled or whatever the default name is - not Macintosh HD.

Then when the installer runs, you might need to look at the install log (press command 3 and command L when the install starts) or we'll need to chase down where or if your installer is saved to disk after the install aborted.

In some newer hardware - you need to be connected to the internet with no firewalls so the installer can go get the components for the hardware - perhaps that step is failing and the install log would likely show that.

Here is Apple's full steps on the erase - so choose it over my steps above if mine fail you.

  • The issue here is that I don't have the option 'erase' on the actual top-level element. But I think I have found the solution - I googled for 'remove Fusion drive' and used diskutil cs to remove it. But that split the drive into 'conventional' 1 TB and around 120 GB of the 'fusion' part. So I used diskutil to 'join' the two, and the install actually, incredibly looks to be working. Thank you for that - I hope to have a working Desktop Mac again soon. :-) – Darren Matheson Dec 17 '17 at 16:42
  • @DarrenMatheson There should be a big warning - Fusion Drive in play. That complicates things a great deal - even worse when they are DIY fusion drives. Please be sure to edit my answer with a “this fixed it for me” if you want to choose it as the “answer”. Or make your own answer and select it. – bmike Dec 17 '17 at 17:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .