1

I'm unable to activate Apple Music on iTunes 12.7

When I go to Preferences -> General There is no Show Apple Music option. Apple music works fine on my iPhone.

How do I enable Apple Music on iTunes?

enter image description here

  • Did you look under "iTunes > Preferences > Restrictions", if "Apple Music" has been disabled? – Redarm Dec 16 '17 at 21:36
  • I just checked and its not disabled. @Redarm – user268244 Dec 16 '17 at 21:48
1

The solution was to go to Account on the top bar and then click Authorisations-> De-Authorise This Computer and Authorise again. After this the Apple music will be shown in iTunes Preferences.

0

First be sure you are logged in with the same Apple ID on both devices. Then go to iTunes > Music, and click on "For You" You can then either choose "Try it now" (if you do not have a subscription) or "Connect"

You must log in to answer this question.