3

I recently updated my iPhone 6s from iOS 10 to iOS 11.2.

Together with the update the device started really annoying me by turning on Voice Control on headset button press. It gets turned on approximately in 30% of the cases. May be it reacts on a longer presses, but anyway I'd better turn this off.

I used to use this button to play/pause music and it worked perfectly with iOS 10. I also didn't change my habits - I press it in exactly the same way like I did it before.

Voice Control itself is turned off on my device. I used the "Turn off Voice Control on your iPhone" article from the apple documentation to ensure I did it properly.

There is also quote in the documentation:

If you're using a headset, and it unexpectedly activates Siri or Voice Control, make sure that your headset is fully inserted into the device.

But it is not my case - the headset is fully inserted. I'm also using the headset provided with the device.

  • Have you tested this with a new pair of EarPods? I'd recommend AirPods if you have the budget and are already buying new headphones. – JBallin Dec 28 '17 at 20:48
  • @JBallin thanks, may be I'll try. I use standard wired headset because I'm afraid I'll lose EarPods right after I by them. I have pretty large ears and headphones drop out from time to time. – Sasha Shpota Dec 28 '17 at 21:27
  • Valid concern. Note they have the same fit as EarPods and can be tested in Apple Stores (try jumping around). They also have find my AirPods. – JBallin Dec 28 '17 at 22:06
1
+50

Disable "Siri & Dictation" in restrictions.

  1. Go to Settings > General > Restrictions.
  2. Enable restrictions and set a passcode if you haven't already. Otherwise, enter your restrictions passcode.
  3. Disable "Siri & Dictation".
    Siri & Dictation is disabled in Restrictions on iOS
  • Doesn’t help. Voise controll is still turning on via headset button press. – Sasha Shpota Dec 29 '17 at 23:12
1

I had the same problem with iOS 12 / iPhone X. Every time I tried to start/stop my music, Siri was activated when I pressed the headphone button a millisecond longer then normal. I even deactivated Siri in my settings!

So I activated Siri and noticed, there was another language/voice set than the one who appeared when I pressed the button.

The solution was to deactivate Siri with the exact voice/language setting, which was used when Siri showed up the whole time.

  • Thank you for your answer (+1). I can't test the solution as I left iOS in favour of Android. – Sasha Shpota Feb 15 at 11:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .