My mac was turned off during the High Sierra update and now just gives me the flashing question mark when I turn it on.

If I boot into recovery I can't select my startup disk because the OSX Base System disk image is 'booted'. It won't let me unmount it either.

I can see my start up disk but I can't boot into it.

Can anyone help with this?



  • Have you tried Internet Recovery? Hold Option-Cmd-R or Shift-Option-Cmd-R – Allan Dec 15 '17 at 9:21
  • I haven't. I can't connect to the net here though unfortunately. Would this give the option to recover into my existing harddrive with my files on it? I can reinstall a fresh OS but I want to get my files back is all. – Martin Dec 15 '17 at 9:31
  • I have no back up I'm afraid. When I open recovery I have the option to recover from a time machine back up but as I don't have one, it doesn't work. – Martin Dec 15 '17 at 9:36

FTW if anyone is experiencing this I solved it by running the “faulty” computer on target mode and using its disk a boot disk on another MBP did all the update process with no problem at all. Then restarted and it came back to life.

| improve this answer | |

Yes you need to go to Disk Utility and select the Macintosh HD disk and click First Aid and Repair it. If the repair works out and the hard drive is OK then quit that menu and go up to Startup disk and see if the disk is there. If it isnt there, then go back to MacOS utilities and reinstall MacOS and then select that hard disk. If the hard disk doesnt pass the repair or first aid, I recommend getting a new hard disk since that one is either bad, or about to be.

An erase and then install will let you know if this storage is reliable, so check your backups and then consider a clean erase from recovery boot.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged .