0

I followed this tutorial to set up a proxy using an AWS instance. I was able to do so, and upon running this command:

ssh -L 3128:localhost:8888 -i /path/to/yourkey.pem ubuntu@xxx.xxx.xxxx

I am able to connect to the instance. However, my mac still doesn't use this machine as a proxy (checked this from my IP, it was still the same as before using a proxy).

I have checked Auto Proxy Discovery in the Proxy Settings on my mac, but that still didn't help. Any help resolving this would be highly appreciated.

1

Auto Proxy Discovery works either via DHCP or via DNS queries to find out where to fetch a special file called "wpad.dat" or "proxy.pac".

Further reading: Web Proxy Auto-Discovery Protocol

Neither your localhost nor the remote AWS instance is configured as valid proxy in your DHCP or DNS-server (if you run any of them at all - most routers don't count because you can't configure DHCP options and/or it's only a DNS-proxy server).

You have to configure the proxy manually - either in the browser settings or in System Preferences > Network > choose interface > Advanced... > Proxies.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .