9

Probably even since some very recent macOS update i'm experiencing quite frequent crashes of SMB connections i use which run on Windows Server 2016 on a local vmWare Fusion machine.

Performance is normally absolutely fine but especially when i'm copying or creating new Files the folder listing blanks out and i get the beach ball. Finder is completely unresponsive and also trying to force umount via Terminal is of no help. Can't properly shut down so only a hard reboot is left to do.

I've tried mounting alternatively via cifs:// instead of smb:// but no luck (except slower performance) and also seen this happen the day before on a colleagues MBP.

Pretty much the same as someone reported back when Yosemite arrived. No answer here as well. Older quite similar question: Samba issues (deadlocks and instability) in OSX 10.10.1?

I can find many similar error descriptions on various older posts in the apple discussion forums but none ever had any solution.

Tried this (https://support.apple.com/en-us/HT208317) as well but didn't make any difference.

So trying here, anyone seen this behavior and knows how to get this fixed?

UPDATE January 12th, 2018:

Some new suspicion. I have a lowered MTU size configured due to a static VPN in the network to MS Azure cloud machines. I recently lowered the MTU even further down to 1400. After that i was experiencing Kernel Panics on the WiFi device instead of the SMB deadlocks. After raising MTU back to 1472 the Kernel Panics stopped and the SMB deadlocks returned. Now i've reset the MTU to the default of 1500. So far no more deadlocks or Panics, but it's been only a couple of hours with that change.

UPDATE January 23rd, 2018:

[default]
streams=yes
soft=yes
signing_required=no
protocol_vers_map=2
file_ids_off=yes

Is my final /etc/nsmb.conf which resulted in stable usage of SMB shares for over a week now.

  • 1
    Same issue here. We have a Server 2012R2 file server, and we can't copy files back and forth after High Sierra. Finder locks and we have to hard reboot the Mac. Same issue persists after MTU changes, the 'sudo /usr/libexec/configureLocalKDC' command, and even when disabling .DS_store files and local disk caching. Macs on 12.12 and lower are not having this issue. – IAmTheSquidward Jan 12 '18 at 19:41
6

Got a workaround that worked in our organization. This changes for macOS the SMB behavior to v2. Changed the following setting in the /etc/nsmb.con file.

#!/bin/sh

echo "[default]" >> /etc/nsmb.conf
echo "protocol_vers_map=2" >> /etc/nsmb.conf

exit 0
  • Thanks for the suggestion. Added this setting here and will see if it has an effect. – neongrau Jan 14 '18 at 17:24
  • I've added your suggestion as well as some other options that were suggested on various sites on my searches. Haven't had any deadlock or kernel panic for over a week now :) – neongrau Jan 23 '18 at 13:17
1

Possibly this will help others.

https://support.apple.com/en-us/HT208209

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Apr 24 '18 at 16:49
  • I would add this to comments. – JBis Apr 24 '18 at 17:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .