5

When I add a WIFI network to my MacBook Pro, it is automatically synced with my iPhone. This is OK on some networks, but if I am using my laptop at a company that blocks certain ports, such as those for external email (e.g. Gmail), I don't want this to be blocked on my phone too.

So, I removed the WIFI network from my iPhone so I can get my email, but now my MacBook has also removed the network, which I need to do my job.

Is there a way to prevent this from occurring? That is, can I have a WIFI network on my MacBook Pro and not have it on my iPhone?

3

This exact issue has also been a thorn in my side, as I frequently do not want my iPhone on the office Wi-Fi network for one reason or another.

A loophole that has been working for me lately (your milage may vary) is to forget the network in question from the iPhone, and then rejoin on the Mac. Its probably a bug, but I've found that I get several hours with the iPhone on cellular and my computer still on Wi-Fi this way. The phone does, unfortunately, rejoin the network once iCloud Keychain figures out what is going on and syncs up.

The only permanent solution I have found so far is to disable iCloud Keychain completely on the iPhone. That way, since the iPhone will not share passwords with your other devices, when you forget the Wi-Fi network on the iPhone the Mac will be unaffected.

Since I quite like iCloud Keychain and use it frequently, I find this a less than satisfactory answer. However, it will result in the desired outcome here.

0

In iOS 11 you can disable Auto-Join.

  • Tap Settings > Wi-Fi.
  • Tap i next to the network name.
  • Make sure that Auto-Join is off.

Join Wi-Fi networks automatically https://support.apple.com/en-us/HT204497

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .