Before upgrading to High Sierra (i.e. when using Yosemite/El Capitan/Sierra) I constantly hid file extensions by hitting enter and manually removing the file extension from the file name. After upgrading to High Sierra, I noticed this no longer applies. Instead, I have to go to the file info via cmd+I and manually check Hide extension. As for Finder preferences, Show all filename extensions is de-selected.

How can I restore the previous behavior, which is very comfortable to me?

  • Removing the extension alters the file name not hides it. – Mark Dec 14 '17 at 13:05
  • Which is exactly what I'm looking for - I don't want to see the file extension as part of the file name. – asafc Dec 15 '17 at 22:23
  • Removing the extension(ie editing the file name) changes the behaviour) e.g. will not open on double click - Is that what you want to do? – Mark Dec 16 '17 at 8:33
  • No. What I was describing is the possibility to hide the file extension from the file name by deleting it, without changing the behavior of opening the file / icon displayed. – asafc Dec 17 '17 at 9:06
  • But that is not what you were doing. You described changing the file name not hiding the extension. – Mark Dec 17 '17 at 10:20

As others have commented, you weren’t hiding the file extensions, you were deleting them from the file name itself. This will impact how the file functions. But, if you haven’t had a problem so far, great. Just avoid doing it from now on.

As you’ve noticed, there is an option in the information pane to hide the extension. Oddly, I can’t explain why you’ve only noticed this now. It has been there in earlier versions for quite some time.

The only way I’m aware of to get rid of file extensions is to make sure the Finder Preferences option you mentioned is unchecked, then batch select all the files of concern to you and hit ⌘+Alt+I to bring up a single information pane summarising all the selected files. The checkbox to hide extensions can be checked and it will be applied to all files in your selection.

With the global preference set not to show file extensions, my feeling is that new files created will, by default, not have their extension visible.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.