1

Need some urgent help with my unruly Mac (faced with the prospect of erasing my hard drive after 150 days without backup...)

Here is the problem that I have. My Mac got quite slow and I restarted it and upon the restart I got a prohibitory sign, which is like a crossed out circle. I read that the solution to this would be reinstalling the OS in recovery mode (Cmnd+R) which I tried to do. The problem is that my hard drive is encrypted using Fire Vault so I need to unlock it before the OS can be reinstalled on it. Unfortunately, there is a known bug where the Fire Vault password is not recognized in recovery mode (I know a 100% it is the correct one, but the mac just rejects it). Again, upon googling I found that the solution to this problem would be to go to the Terminal from recovery mode and unlock the disk from the Terminal. (here is the thread where I found the solution https://discussions.apple.com/thread/3348646 )

Now I tried to follow the directions in the thread which are:

  • find the core storage UUID by doing diskutil coreStorage list

  • using the UUID of the locked HD, type in "diskutil coreStorage unlockVolume "

Now the current problem that I cannot solve arises when I type in diskutil coreStorage list. I get the error "No CoreStorage logical volume groups found" which means that my CoreStorage has been removed. This is where I am right now, and I could really use some help of someone who knows how to work with these things. As far as I understand, I either need to make my encrypted HD a core storage unit OR to find a way to unlock it without making it a core storage unit. I am scared to do either though because browsing through help files didn't give a simple answer and I am worried I will do something irreversibly bad.

Thank you very much!! Attached is the output of diskutil list diskutil output

  • 2
    What is the output of diskutil list? Please make a picture of the screen showing the result and add this to the question – nohillside Dec 12 '17 at 20:08
  • Hello, I will attach the picture. It is only the top part but it continues the same way until disk20. – Temino Dec 15 '17 at 6:50
1

If you have access to another mac, a potential way to be able to back up your data is to boot in target disk mode https://support.apple.com/en-us/HT201462. This will mount your internal HD on the host mac like it would a normal external HD and the OS will immediately prompt you to unlock it using your FileVault pw. I have encountered basically this same bug you are describing in the past and have had success unlocking with this method, even if it fails from recovery.

If you don't have another Mac handy, you can also reset your FileVault pw (I understand that you know it, but this method may still get you back into the machine) by opening terminal from the utilities menu in recovery (or internet recovery, whichever) typing resetpassword, hitting enter and following the prompts. However, if you don't have your recovery key or apple ID access set up this method won't be much help. Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .